Internet sharing on a Vista PC

  jz 21:49 29 Mar 07
Locked

My Vista PC is connected to broadband via an NTL modem, and connects into this PC via USB.

I want to connect an XP PC to my Vista PC using a crossed network cable, and be able to have internet access on the XP PC via this network cable.

I've connected the two PCs together with the crossed network cable. How do I set up my Vista PC to enable internet access on the XP PC?

  Paul-230483 09:32 30 Mar 07

You need to connect both pcs together with network cards not via usb. You will need a DSL router then you can connect to the internet.
By using a router the machines can connect to the internet. Buy a 4 port DSL cable router.

  HappyTrucker 10:17 30 Mar 07

You've connected the PCs via RJ45 but you haven't said whether you've set up your network yet. Set up a network betwen the two systems then you can move on to sharing the internet connection.

Basically you go to the Network Connections on the Vista machine, right click/properties and tick to allow other PCs to share the connection. You then have to set the other PCs Internet Options LAN settings to use a proxy.

Put Internet Connection Sharing into the help and support box in Vista. This details the procedure quite clearly. If the info it dishes out doesn't help, or you need clarification post back.

  riiverstock 10:45 30 Mar 07

You may find that when you run Network Map on a Windows Vista-based computer, computers that are running Microsoft Windows XP do not appear on the network diagram.

This problem occurs if the Link-Layer Topology Discovery (LLTD) Responder component is not installed on the Windows XP-based computer.Here is the MS link click here

Recently I did the same but I am on ASDL Tiscali.
I had the internet coming through the XP then to the Vista pc.

The Vista pc really does most of the work itself.

I had quite a few initial firewall problems between McAfee and XP firewall.

My Computer->My Network Places->SetUp Home/Office Network on XP.

  riiverstock 10:54 30 Mar 07

Forgot to say ,the name you give to your home network must be the same on both the machines.
The default in both cases will be MSHOME.

If you change this to something like MYNETWORK then this is when you have to make sure both pc's use this name.

  1832bchs 14:41 30 Mar 07

Just to say that whilst the default network name is MSHOME in Win XP, it is WORKGROUP in Vista.

  jz 21:13 30 Mar 07

Thanks for your replies everyone. I'll look into what you've all said and have another go over the weekend.

I used to have this working on an XP PC which was connected to the internet via a USB cable modem, and another XP PC was connected to this PC with a cross-over network cable. It all worked fine. But now I have a new Vista laptop which is connected to the USB cable modem (the internet works fine on it) and I can't get the other XP PC to see either the Vista laptop's files on its harddrive or the internet. DHCP seems to work on it since it gets a sensible IP address (192.168.0.17 I think). I've set the Vista laptop to 192.168.0.1, and have enabled Internet Connection Sharing. The Vista laptop can see the XP PC (ie I can get onto its hard drive) but the XP PC comes up with a "network connection has limited connectivity" balloon, or something like that from the network icon in the notification area.

I'm wondering if I need to change some security settings on the Vista PC. Or maybe I've forgotten how I set up the previous XP PC!

  jz 21:15 30 Mar 07

...by the way, I'm using the built-in Vista firewall, if that has any bearings on it.

  jz 11:50 15 Apr 07

Well, after many attempts, I still cannot get the internet on my XP PC. I tried a second XP PC but that didn't see the internet either. I followed the instructions on the Vista help topic, trying DHCP (which it recommended) then when that didn't work, trying a fixed IP address 192.168.0.1 as before. I don't think that the LLTD issue is relevant, since the PCs can see one another. The workgroup names are (and always have been) the same.

  riiverstock 16:58 15 Apr 07

jz I would switch the XP firewall off and then run the XP home network setup routine again.

I had many firewall issues when setting up my network.
As I said above I had the XP set as the master which is the main difference compared to your setup.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…