Connected to WIFI but no internet connection

  Toonarmy945 15:22 30 Oct 14
Locked

My laptop says I am connected to my WIFI network however when I open a browser the message 'no internet connection' appears. I have tried to plug it directly into the router via an ethernet cable but this also was unsuccessful. Does anyone have any idea what might be causing this and any solutions?

Thanks!

  Fruit Bat /\0/\ 17:53 30 Oct 14

What op system and what browser are you using?

  Toonarmy945 18:03 30 Oct 14

Windows 7 Chrome and IE both aren't working

  Woolwell 19:02 30 Oct 14

Reboot your router.

  Toonarmy945 19:29 30 Oct 14

i am getting an error upon diagnostic saying that 'the device or resource (DNS server) is not responding' any ideas?

  Woolwell 21:14 30 Oct 14

Have you restarted the router?

  Toonarmy945 22:16 30 Oct 14

Yeh it didn't fix the problem :/

  mole1944 06:11 31 Oct 14

Is it your own router or like mine i'm with virgin. If company supplied phoen them for a new one,if its your own looks like possibly a new router. Another way is instead of a reboot try swithing it of for a few minutes then on again.

  BT 08:17 31 Oct 14

If you are connected to your WiFi network its not the Router at fault its the Modem. If you have a combined Router/Modem (Virgin/BT etc) the whole thing needs resetting. Switch it off and wait a few minutes then switch on again. If you have a separate modem check the connecting cable between your Router and Modem, and Modem to wall socket. Switch off the modem and wait a few minutes before switching on again and watch the lights to make sure they are working.

  alanrwood 08:24 31 Oct 14

BT has it right. Your network is most likely OK but the connection from your router to the internet via the internal or external modem. Check the connection to the wall socket is OK. Switch EVERYTHING off for a couple of minutes then reboot the Modem/router and see if the Internet LED is lit correctly. Then reboot your computer and see if it now connects.

If not it is time to speak to your ISP tech support.

  onthelimit1 08:43 31 Oct 14

May well be a winsock problem. Follow the sequence here. and see if that sorts it.

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…