cannot install tp-link wifi adaptor, the data is invalid

  winterinthesun 12:19 16 Sep 13
Locked

I have been trying to install a tp-link TLwn821n wifi adaptor to my friends windows 8 computer. It seems to install ok and then asks me to reboot the computer. upon reboot the drivers are not installed. The message reads 'windows found driver software for your device but encountered an error when attempting to install it, the data is invalid' I have installed this stick to my windows 8 computer and my windows 8 laptop with no problem at all. I have taken the latest drivers from the website.

Has anyone got a fix or know what the problem is,

Many thanks

  winterinthesun 12:46 16 Sep 13

Hi, Thankyou for your awnser

I have tried plugging it before install but this does not work. it also does not have wifi installed. As I mentioned its not problem installing on both of mine but will not on this computer. I have checked device manager when I have tried installing it and there is a yellow exclamation mark and when I check properties there are no drivers installed. When I try to reinstall the driver I get the above message that I have posted. I have tried uninstalling avg, turning the firewall of as well but it just will not install. I have even tried installing 2 other sticks (a brand new Belkin and an older netgear)and the same happens but they will install on my 2 computers without a problem,

Any ideas?

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

VFX Oscar nominees 2017: Discover how the visual effects were created

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…