Autoplay in Windows 7

  LMcG 16:40 26 Mar 10
Locked

Hi

Can anyone tell me how to get autoplay to work in Windows 7? I have checked the box to 'use autoplay for all media and devices' but still nothing happens. I have tried cds and usb pen drives but nothing appears. I have to access them through (My) Computer.

Thanks

  rdave13 21:32 26 Mar 10

In the list that shows (under the box you ticked) you will also need to select the default program to open whatever you load.

  rdave13 21:36 26 Mar 10

Should have added that whatever changes you make then click on the save tab at bottom.

  LMcG 11:08 27 Mar 10

Hi, I have done that but still nothing happens. Everything is set to 'Ask me every time'

  rdave13 16:49 27 Mar 10

Try setting back to default. Click on the 'Reset all default' tab in AutoPlay then click save.

  BurrWalnut 18:53 27 Mar 10

If you cannot make the changes using Control Panel > All Control Panel Items > Autoplay, try changing a registry key as follows:

Click the Windows Orb (Start), type regedit, press Enter and in the left pane navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom. In the right pane there will be a value called Autorun, double-click it and change the value to 1. To be safe, create a system restore point first, just in case anything goes wrong.

  LMcG 19:22 30 Mar 10

Hi, thanks for your advice. Tried everything that has been suggested but still not working. The registry was already set to 1.

  rdave13 00:42 31 Mar 10

Have you checked Shell Hardware Detection is started and on automatic in services?
Start- search box type services. Click on services (top one in list) and scroll down to Shell Hardware Detection. Double click it to check or change settings.

  kristain 12:25 31 Mar 10

Double-click "My Computer", select the CD/DVD drive and right-click. In the menu that appears, select "Properties". The Properties dialog box will appear.
Select the tab "AutoPlay."
Choose an AutoPlay option "Restore Defaults, "Prompt me each time to choose an action".
select "OK" to save your changes.

  LMcG 21:58 08 Apr 10

Thanks everyone for your help. It is only CDs/DVDs (whatever the content) that do not autoplay for some reason. USB and external drives are fine.

  Technocrate 08:16 13 Apr 10

method 1:-
1. Go to Control Panel\Hardware and Sound\AutoPlay.

To Enable:
At the top, check Use Autoplay for all devices and Click Save.

To Disable:
Uncheck Use Autoplay for all devices and Click Save.

method 2:-
1. Click Start and in the Search box, type gpedit.msc and press Enter.
Now browse to Computer Configuration\ Administrative Templates\ Windows Components\ Autoplay Policies\ Turn off Autoplay.

To Enable:
Change the value of Turn off Autoplay to disabled.

To Disable:
Change the value of Turn off Autoplay to enabled.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…