ASUS X555LN Low Quality Sound Through Speakers

  Sharkley 14:10 16 May 15
Locked
Answered

Hello! Lately I am dealing with a huge problem that I can't solve. I have Asus x555ln and Razer Electra headphones. The headphones have been working earlier on this laptop (and are workinkg, I've tried them on bunch of different platforms, Samsung phone, my sisters PC, and no problem with the sound) but then Windows 7 updates have popped out and I've just updated my OS, but after restarting my computer, headphones didn't sound good. No bass, squeaky noise. Also when headphones are plugged in the sound when I start skype goes through laptop's speakers. I really don't know what to do, because I did do several solutions, which didn't work. If anyone have been facing same problem or knows the solution, please write me back ASAP.

Thanks in advance

  Daisy_Michael 12:45 20 May 15

Tools >> Options >> Audio Settings (that's to deal with the issues in SKYPE).

For other issues, perhaps you'd have to highlight the details about your sound, if it's built-in, make model, OS (32 or 64), normally the drivers are responsible for all such things.

  Sharkley 13:40 20 May 15
Answer

Thanks for reply, but i didn't catch you exactly at the first part of the sentence. If you're asking me bout OS its win7 x64. And i have updated/downgraded my drivers dozen of times and still nothing.

This thread is now locked and can not be replied to.

Samsung Galaxy S8 review

1995-2015: How technology has changed the world in 20 years

This 2D animation about monsters is illustrated in a Van Gogh painterly style

How to get WWDC 2017 tickets