Advent Roma 2001 Battery issues

  mbarker20 27 Feb 12
Locked

I have had my Advent Roma 2001 (Windows 7) for about a year and a half now, it now only holds about 5-10 minutes of battery even though it says 100% 1 hour 6 mins remaining, usually cutting out around 80% battery.

I have tried numerous times to edit the power options and power plans but nothing worked, i have now set the battery settings to default.

Another Roma 2001 user is experiencing the same issue, after purchasing a new replacement battery, he/she has the same issue.

Any ideas? is this a hardware issue?

  ams4127 28 Feb 12

You would probably be far better off posting this question on the Advent forums.

As a general point about laptop batteries, try getting it professionally tested.

Do you run on the battery all the time or do you use mains? The battery in my Evesham laptop has lasted for 9 years and is still as good as new.

Advertisement

This thread is now locked and can not be replied to.

Should I upgrade to Windows 10? 8 reasons why you should upgrade to Windows 10... and 2 why you…

We are being sold the ability to spend money we don't have. And we love it

Encore creates eerie effects for Spielberg's new TV show The Whispers

How to use Apple Music in the UK: Complete guide to Apple Music's features

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message