Is the site getting better ot worse

  mole1944 14:18 PM 30 Oct 12

Just lately i find this site splutters and jumps all over the place,i'm on ie9,is it me my machine or the site.Even replying to a post is now getting to be more trouble than it's worth. Sorry to moan but things do seem to getting worse,i've noticed some of the quieries seem very old and are on the top of the pile in each section.

  wiz-king 14:23 PM 30 Oct 12

It's IE9 that's the problem - in my opinion. I have tried Firefox, Chrome, Opera and IE9 and IE9 gives me most problems! AND it gives me problems with other websites including my own --grrrr.

  Bing.alau 14:28 PM 30 Oct 12


The threads at the top stay there because they are current. As they get older and replies lessen so they gradually go lower and lower down the page until they either disappear or get resurrected by someone later. There's nothing unusual about that.

Whether it's your machine or just you, can be found out by buying a new machine or getting a "proper man" in to check it for you.

  Fruit Bat /\0/\ 14:38 PM 30 Oct 12

IE8 is bad as well

no problems using FF

  Phil Ocifer 15:41 PM 30 Oct 12


The pile isn't going down very fast because not many people are using the forums, IMO because they are slow, clunky, problematic and full of adverts.

I think we'll be going round in circles here if we're not careful.

  Forum Editor 16:02 PM 30 Oct 12

Phil Ocifer

With respect, you have no idea how many people are using the forums. Don't make a judgement based on the number of posts you see - that's not any kind of indicator of total traffic. Over 5 million pages a month are clicked on our site overall, and an awful lot of those are in the forums.

As for being "slow, clunky, problematic and full of adverts." Current average page loading times are the fastest they have ever been, we've ironed out many of the problems that plagued us a while ago, and adverts are necessary if we are to continue to provide what is a huge free resource.

One which you seem to use largely for the purpose of making negative comments.

  Forum Editor 16:06 PM 30 Oct 12

"i'm on ie9,is it me my machine or the site."

It's probably IE9 in the main - we're trying to sort out why at the moment, but my guess is one or more of the ad servers.

Have you tried using Google Chrome? You might get a pleasant surprise.

  al's left peg 16:27 PM 30 Oct 12

I use Safari and it's the same on that. I don't think it's fair to complain about adverts, after all it's still the best place for free advice in my opinion.

  Flak999 16:29 PM 30 Oct 12

For me personally, the site at the moment is very fast. I am using chrome and I find that as a browser it is fast and very problem free, as is this site currently! (will I regret that comment?)

  T0SH 16:45 PM 30 Oct 12

When I access any forum post with (Tcpview) running I see anything up to 39 or more tcp ports opening , on most other sites the norm is 5 or 6 on the odd occasion up to 12 , I also get occasional warning that a script is causing IE run slowly, if I choose yes to stop it the page then seems to respond almost instantly for a short while ?

Cheers HC

  Forum Editor 16:47 PM 30 Oct 12


You and me and our big mouths.

We've disabled some of the behind-the-scenes items that affected page loading speeds, but it's an ongoing thing. Overall, site traffic has increased considerably of late, and although we're delighted to see it happen there can be penalties in terms of performance at peak times.

We watch the server loads in real time, and we can see when there are unexpected traffic peaks. That's when there's a possibility of page loads slowing. We'll keeping trying.


This thread is now locked and can not be replied to.

Best Android apps 2015/2016: Best apps for your new phone or tablet - what apps should I download?

1995-2015: How technology has changed the world in 20 years

Uniqlo uses your brain waves to find your perfect T-shirt

What everyone thinks of the new Steve Jobs movie | 21 Facts about the Steve Jobs film | PLUS:…