PCA links inconsistency

  Covergirl 23:13 PM 02 Dec 11

I notice that when you are in the forums, just below the menu bar (News Reviews How-to Forums), on certain forum index pages there are links to all the other forums, whereas on others, just your current location (e.g You are here>Homepage>Forums>Helproom)

The forums with ALL the links are Business, Speakers Corner, Mobile World and Windows8.

I find that having all the links available is more convenient.

Anyone else any preference?

  Aitchbee 23:30 PM 02 Dec 11

I have not noticed that,Covergirl. I will look out for what you are talkin' about. I, invariably just use about 3 clicking points on the PCA website.

  Graphicool1 00:01 AM 03 Dec 11


"Anyone else any preference?"

Yes, i preferred it when, after the change over, briefly they had a list of the 'FORUMS' at the bottom of the page. It was so convenient, to just drop to the bottom and click on a forum.

  D@ve 01:54 AM 03 Dec 11

Graphicool1, they're still there aren't they? This is what I see under this reply box (it hasn't copied and pasted in quite the same layout - it's 3 lines on the actual webpage):

"Check out PC Advisor's other tech forums

Windows 7
Absolute Beginners
Speakers Corner
Windows Vista
Digital Home
Mobile World
Beta Testing Forum
Windows 8"
  simonjary 09:53 AM 04 Dec 11

Thanks for pointing out the inconsistency. We'll get that fixed.

Links to all forums hasn't changed - should be on all forum pages.

Cheers, Simon

  bremner 10:13 AM 04 Dec 11


Whilst we are on this subject I fairly regularly click on the "Last Response" time and get a thread with only the initial posting as opposed to the last page of postings.

  Forum Editor 10:30 AM 04 Dec 11


I've never experienced your 'last response'problem, and I've just been trying to make it happen, but can't.

Has anyone else had the same problem as bremner?

  lotvic 10:43 AM 04 Dec 11

Yes, same as bremner but not for couple of weeks. It seems ok for me at the moment.

  bremner 11:05 AM 04 Dec 11

I usually access the site form an iPad, this may be significant I don't know. I am currently on my iMac but I have just clicked on the Last Response for this thread on my iPad and got only the initial post as I have previously described.

  bremner 11:15 AM 04 Dec 11
  Forum Editor 11:36 AM 04 Dec 11


Thinking it might be an iPad thing I tried it on my iPad, and I didn't get the same as you - I got what I should have seen - the last page of the thread.

I then tried it in Safari on my PC, and again, everything worked perfectly. I haven't seen any other reports like yours, so perhaps the problem lies at your end?


This thread is now locked and can not be replied to.

Sony Vaio Z Canvas release date, price and specs: Another Surface Pro rival but for the US

1995-2015: How technology has changed the world in 20 years

Adobe unveils Sketch-rival Project Comet for UX design

How to fix iOS 9 problem iPhone stuck screen, unresponsive, no swipe, frozen, can't turn off