zone alarm (firewall)

  garybaldy 18:30 19 Feb 03

Please advise as ive recently installed zone alarm but now i cant access a certain program .ive contacted the program service line who have told me i need to adjust the setting on the firewall .can anyone let me know how i do this as it is very important that i have access to this program.thanks in advance.

  Blix 18:44 19 Feb 03

With ZA running, right click ZA icon bottom right, hit restore Zone Alarm centre, When it opens click program control, then programs....this should list the programs on your can adjust access by changing the "X,?, and check mark" for each program. Hope this helps.

  recap 18:46 19 Feb 03

garybaldy, you should see the zonealarm icon in your syst tray (bottom right near the clock), double click the icon. Select program control, from you can configure the access for your programs.

  garybaldy 18:58 19 Feb 03

thanks guys ,but ive just followed Blix instructions and tick all 4 boxes but the comunication has failed again .the program service line have said that it is the firewall causing the problem any further ideas?

  recap 19:05 19 Feb 03

garybaldy, you can remove a program from the list. Right click the program and select remove. You can always add it back at a later date.

  garybaldy 19:19 19 Feb 03

in order to run the program i wanted i shut down Z/A but how do i restart it .do i need to reinstall.And how come i cant run the program when Z/A is running after i ticked all 4 boxes in the program menu.

  worf 20:22 19 Feb 03


When you installed ZA it will have put the program shortcut in your Programs menu (Start Button/Programs). If you disable ZA you need to go to START / Programs and select the ZA shortcut it will then start up again.

What program are you trying to allow access to the internet with?

Right click the ZA Icon in the System Tray (bottom right of screen). Now select "Restore ZA". Now select the PROGRAM TAB. In th eprograms menu you should see PROGRAMS/ACCESS/SERVER. Scroll up or down till you find the program that you are trying to access the internet with.
In the ACCESS list should have two GREEN ticks if not left click in the list and select ALLOW. On the server side should be two RED crosses if not do the same routine as for the other list.
Once this is done right click the program abd select OPTIONS.
You should now have a window with PORTS and SECURITY Tabs. In the PORTS tab make sure "Allow access to all ports and protocols is selected. Now go to the SECURITY tab. The only thing you need to make sure is checked in this tab is in the "AUTHENTICATION LEVEL" make sure "Authenticate programs and components" is checked.

I am trying to do this from memory as I am running the Pro version which is different to the free version.

Find the FIREWALL tab and in there you should have tanother window with two more tabs MAIN and ZONES. Internet zone security should be set to high and trusted zone security set to medium.

Now go back to PROGRAM Control and in there should be three tabs MAIN/PRPGRAMS/COMPONENTS. Go to the MAIN TAB and make sure that Program Control is set to Medium (learning mode) and make sure the Automatic lock is off.

I think that is about it.

What you should get now every time a program tries to access the internet a notification window pop up asking if you want to allow it access. Try your "certain program" again and see if a notification pops up. If it does make sure you allow it access. When the window pops up it will ask do you want to allow (what ever it is)access to the internet, check the remember this next time box and then click allow. It will then ask if you want to allow it to act as a server. Do the same again but dissallow access.

  garybaldy 22:09 19 Feb 03

Wolf im in need of further help,i have selected 2 green ticks in the access panel and 2 blue question marks in the server panel is this correct.then you say to right click the program abd select option ,i dont know where this is.Ive also set the security to high and trusted zone to medium.the program i am trying to access with zone alarm on is internet banking ,as i say i can access this when the firewall is shutdown.

  worf 11:12 20 Feb 03


The access panel is correct but you want two red crosses in the server panel.
With regards to your other question when you have the program displayed in front of you with the green ticks and red crosses right click on it and select Options.

As i said I am trying to do this from memory but when you right click the systray icon and select "Restore ZA" what does it come up with?

It sounds as if the cookie control is set to high. Is there a cookie control option anwhere once you have the program open. If there is open up the cookie control and set it to OFF. Once you have done this then try reconnecting to your online banking again. If it works close internet banking down and go back to the cookie control and set it to medium then reconnect to your internet banking. If it works then great but if not at least then you know that to use your internet banking facility you have to have cookie control set to OFF. Don't worry about the cookies because you can always clean them off your pc via the Tools/Internet Options menu.

Hope that helps? If not, come back.

  garybaldy 11:44 20 Feb 03

ive selected the ticks and the crosses but when i right click on the program all i get is ADD or REMOVE is this normal.

  garybaldy 11:56 20 Feb 03

when i click the Z/A icon it says ingage internet lock,stop all internet activity,buy z/A pro,restore Z/a control center and shutdown Z/A.

This thread is now locked and can not be replied to.

Nintendo Switch (Nintendo NX) release date, price, specs and preview trailer: Codename NX console…

1995-2015: How technology has changed the world in 20 years

8 things designers (and brands) need to know about the modern woman

How to speed up a slow Mac: 19 great tips to make an iMac, MacBook or Mac mini run faster | Speed…