XP/ME Dual Boot Problem

  zinc3 19:42 08 May 03
Locked

After installing a XpPro/ME dual booting system that worked fine (Millenium c:, XP d:), i had to re-install a ghost image of ME on c. After doing so i lost the boot menu on startup, which means i am unable to access the XP side. The image was made before i originaly set up the dual boot system and i can now only acess ME.

Is there any easy way of restoring the menu so i can access XP again without re-installing? This would save me alot of time. The menu was created by XP Pro and not partiton magic.

Thanks

  powerless 19:45 08 May 03

Are you using one hard drive or two?

  temp003 12:47 09 May 03

Restoring the old ME image of C has removed the XP boot files. They are ntldr, ntdetect.com and boot.ini, and in a dual boot with ME, the additional file bootsect.dos

Bootsect.dos is created by XP installation when XP Setup detects 9x boot files on the C partition, to create the dual boot.

There are methods on the web for creating bootsect.dos manually. You could also reinstall XP over the existing copy, but then you will have to reinstall all Windows updates including SP1.

A more convenient way of restoring the dual boot is to start an installation of XP, but without finishing it (you don't want to go through the whole process). When you start an XP installation, XP Setup will copy temporary installation files to the C drive. At the same time, it will put the boot files on to C (after detecting the existing ME installation). It will create a dual boot between Windows ME and Windows XP Setup.

Boot into ME. If you don't have a ME startup disk, create one now. This is just a safety measure, in case something goes wrong, and you can then at least restore the boot files for ME.

While still in ME, put the XP CD in. Select Install Windows XP. On the next screen, select from the drop down list New Installation (Advanced). Click Next. Follow the prompts for product key and so on. XP Setup will then copy the temporary setup files to your hard disk. When it's done, it should prompt you to restart (and will automatically do so if you don't stop it).

Here you don't want to restart if you can help it. If there is a "Don't restart" button, click that. If there isn't, let it restart, but get your finger ready on the down arrow button on the keyboard, so that when the OS selection screen appears (like your old dual boot), you can select Windows ME and not Windows XP Setup.

The time for selection is 5 seconds. But by the time the selection screen appears, you will have lost 2 or 3 seconds. So get your finger ready to select Windows ME.

When you're back in ME (with or without rebooting), go to your C drive and find the file boot.ini. If you can't see it, click Tools, Folder Options, View, and tick show all hidden files and folders, untick Hide protected operating system files, and untick Hide file extensions for known file types. Click OK.

Right click boot.ini and select Properties. Untick the "Read-Only" Box (if it is ticked). Click OK.

Then double click boot.ini. It will open in Notepad. Edit it to read as follows:

[boot loader]

timeout=8

default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS

[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect

C:\="Microsoft Windows Millennium Edition"

This assumes that your C and D partitions are on the same hard disk.

If your D partition is a separate hard disk, then the path for the "default" line and for the entry under [operating systems] should be changed to multi(0)disk(0)rdisk(1)partition(1)\WINDOWS

Afer editing, click File, Save. Then exit Notepad.

Restart computer and your dual boot should be restored.

Last step is to delete the folder C:\$WIN_NT$.~BT which is the temporary installation folder for XP Setup.

  zinc3 08:42 10 May 03

thanks for your help boot menu works fine apart
from one small niggle menu now reads:

xp
mill
default

default being the selected option how can i remove it so xp and mill appear only, as the defualt if left causes a error message and a
reboot was`nt on menu prior to problem.

many thanxs zinc

  powerless 08:47 10 May 03

In Windows XP go to Start > Control Panel > System > Advanced > (Third) Settings > Edit > Remove the line where default is.

  powerless 08:50 10 May 03

Don't do that, i'm wrong.

  powerless 08:52 10 May 03

Go to start > Run > Copy and Paste:

C:/boot.ini

Now click ok. Copy and Paste the info that you see and post it back on here.

  zinc3 12:22 10 May 03

[Boot Loader]
Timeout=20
Default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[Operating Systems]
multi(0)disk(0)rdisk(0)partition(4)\WINDOWS="Microsoft Windows XP" /fastdetect
C:\="Microsoft Windows ME"

hope it helps zinc

  powerless 12:32 10 May 03

Well no point in lying. I do not know, have to wait until temp003 wakes up (seems to be a midnight forum person).

  temp003 04:11 11 May 03

Sorry, Powerless, I'm from Hong Kong (GMT+8), that explains my apparently nocturnal posts.

zinc3:

From the sound of things, you seem to have restored the XP boot loader (because you now have the boot.ini file).

I assume you have done some sort of reinstallation of XP (as I suggested or some other way). I think you must have edited boot.ini as well, but at the moment it's wrong. Perhaps my last post was a bit confusing. My posts usually are :o((

I also assume that (1) you now get the boot menu when you start up, (2) you can boot into ME, (3) but you cannot boot into XP.

Steps to take:
If my assumptions are correct (please tell me if they are wrong): First verify that all the XP boot files are there. Boot into ME, go to C, and check that ntldr, ntdetect.com, boot.ini and bootsect.dos are all present. They should be.

I assume you have removed the Read-Only attribute of the boot.ini file (since you have edited it before).

Then all you need to do is edit boot.ini again.

Editing boot.ini -

You haven't confirmed whether your XP partition is the second partition on the same hard disk. The following ASSUMES so.

You must correct me if this assumption is wrong.

Double click boot.ini again, and make changes to 2 lines.

Change the line beginning with "default=" to read as follows:

default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS

Change the first line under [operating systems] to read as follows:

multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP" /fastdetect

Save the changes. Exit Notepad. Restart. Try selecting XP and see if it works.

At the moment, the two lines that I mentioned above (1) do not match each other; and (2) neither line refers to the correct partition in which XP is installed. That's why you can't boot into XP. Change the two lines and you should be able to do it (Hope so!)

  zinc3 18:21 11 May 03

Thanks, the boot boot menu seems to be working fine, the problem was i didnt understand the numbering after partition in the boot file (ie ....partition(2).

The way i understood was that this actually refered to the partitions 'address' on the hard disk (in my case partition 4) so i editited the menu as such. This caused an extra option on the boot menu to appear (Default).

Can you claify why the numbers both have to be '2'? Does this number refer to the number of operating systems installed?

One final question, if i were to make a backup of the files mentitioned (ntldr, ntdetect.com, boot.ini and bootsect.dos)would i simply be able to copy and paste these back into the c: directory if i were to overwrite the partiton again?

Many thanks again to yourself and Powerless for your help.

zinc

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…