XP SP3 no longer showing icon for saved html?

  theDarkness 12:43 25 Oct 09
Locked

I use IE on the net, but only ever to save web pages as a single file format, as Firefox is unable to do it. When I save internet content as single web pages in IE, the pages save and read absolutely fine, but the IE icon for "save pages as a single file" has disappeared! It now uses a standard 'unknown file type' icon, and I dont know how I can get the original html icon to show for each file.

I have tried this guide, but it does not work, and my system tells me the original icon is missing from my system:-
click here

The only major program I have installed recently is MS Office 2007, no doubt that has deleted the original icon, but I dont know how to make it re-appear, especially since MS has given up on updates. Any ideas? Are there any programs out there that are used solely for re-installing original XP icons? thanks

  Graphicool1 14:23 25 Oct 09

Have you tried the following...
Click on 'My Computer'
Right click C:\ drive
Click the 'Tools' tab
Click the 'Check Now' button
Click the box 'Automatically fix file system errors'
Click 'Start'
It may say do you want to schedule for the next time you restart computer?
Click 'Yes' and reboot

  theDarkness 14:57 31 Oct 09

yes tried it on both C and D (partition from C), but it makes no difference? :( its not a big deal since it works all the same, but I dont know of any way I can restore windows xp icons in order for the right images to show again

  theDarkness 15:00 31 Oct 09

i should add that the exact html type it will no longer show the correct icon image for is a web archive ".mht" file

  theDarkness 15:11 31 Oct 09

also tried right clicking on the desktop, selecting properties > appearance > advanced, then changing the icon size, but that made no difference either, seems to be just a saved webpage mht file issue, as all other icons display ok

  VoG II 15:16 31 Oct 09
  beeuuem 15:39 31 Oct 09

You could try Tweak UI from click here - halfway down right of page.
Once installed go to the Repair option and rebuild the icons.

  theDarkness 15:05 01 Nov 09

thanks to both, tried tweak UI and a restart, but no luck! :( tried googling, at first i thought it might be an sp3 problem, but my problem doesnt seem to be that uncommon :- click here

..and thats from 2002 regarding win 95/98! :)

  Sea Urchin 18:30 01 Nov 09

You don't mention that you have tried VoG™'s suggestion - looks fairly comprehensive to me.

  theDarkness 12:22 02 Nov 09

Sorry! :) yes, i tried VoGs solution, perhaps the most obvious one that definately should work-but the icon for saved webpages remained the same. one thing perhaps to note- when adding new 'MHT' and 'MHTML' file types, the default program for my newly created file types stated is always "OPENS WITH: 2007 Microsoft Office component". perhaps this is the source of the problem, but even when choosing a different default program for both newly created MHT and MHTML file types (eg a browser), the icon is the same, the usual 'uknown' type. I also tried creating new icons once again and even restarting the system (you never know!), but its just the same. Its possibly MS Office thats tampered with the icon file image, but I dont want to uninstall that, as I need it! :( lol. thanks for all the suggestions

This thread is now locked and can not be replied to.

What is ransomware and how do I protect my PC from WannaCry?

What I learned from my mentor, Oscar-winning VFX supervisor Phil Tippett

Siri vs Google Assistant