xp reinstallation problem

  Elwell 18:11 07 Nov 05
Locked

I am trying to reinstall xp fom cd but it says it cant find/recognise the hard drive. I think this is something to do with a bios setting but can't figure it out. Any help would be appreciated.

  stalion 18:17 07 Nov 05

you need to go in to the bios press del on boot up and find the settings for forst boot etc.
select cd as first boot

  Fruit Bat /\0/\ 18:22 07 Nov 05

1. switch off open case

2. check IDE and power cables tight at HDD

3. check jumper on HDD in master postion

4. check IDE cable tight at motherboard

5. boot PC, is HDD shown on the POST (first screen)?
If not the reboot enter BIOS CMOS settings. Check HDD settings set to Auto. OR try an auto detct drives (F3), save and exit (F10)

  Elwell 18:56 07 Nov 05

Thanks.

Machine set to run from cd.
Cables ok. Its a Maxtor drive and this is shown on the first screen but in CMOS settings although HDD set to auto, primary is set to DVD and slave to CD/RW. Don't know if that is right.

  Trackrat 19:06 07 Nov 05

Your hard drive should be set up on one IDE cable and your DVD & CDRW should be on the other IDE cable.
The hard drive should show as Primary master and your optical drives should show as Secondary master & secondary slave.
If it is shown the opposite way round switch the two IDE connectors on the motherboard over.

  Fruit Bat /\0/\ 19:07 07 Nov 05

Assuming an IDE HDD

HDD should be plugged into primary IDE and jumper set as master. (this is the important bit)

CDRW plugged to same cable and jumper set as slave

DVD plugged onto secondary IDE cable and jumper set as master.

or CDRW plugged onto secondary cable (same as DVD) jumper set at slave.

Boot settings in BIOS:-
Set first Boot as CDrom (dvd player) second as IDE0 (HDD)
save and exit (f10)

Boot with CD in the drive and it should now find the HDD (set as master on primr cable IDE0)

  Elwell 17:23 09 Nov 05

Thanks

I've checked the cables. (I know next to nothing about this sort of thing) The drive has a red cable which I think is an ATA cable and is very narrow. It is connected securely to the drive and to the monitor. I've checked the Maxtor site for jumper settings. I can see where they are set but I can't see the usual little plastic connector where I thought one should be to make the drive the Master. The DVD and CD are on the same cable - a wide grey thing - and this is connected to the mainboard in two places. I can see the CD is set as slave but it also looks like the DVD is set to same - could be wrong here as the Samsung DVD is not as generous with information as the HP CD. Drive can't be on same cable as dvd or cd because there is nowhere to attach the grey cable. Power cables are all ok. I've run some Hard Disk software to check surface etc.

  Elwell 16:39 11 Nov 05

Checked all cables and settings again. All ok. Run diagnostic software - no problems with disk. Put drive into another machine which runs perfecly on XP. Still no joy. Installed Windows 98 - no problem. So there's something the XP disc is looking for that isn't there. More help would be much appreciated.

  woodchip 16:51 11 Nov 05

inbios it should be set as cd as first boot device hard drive as second boot device

  Skyver 17:00 11 Nov 05

If your primary drive is a SATA drive (the one connected using the thin red cable) you need to press F6 when the XP CD asks if you need to load any 3rd party drivers. I've not had to set up XP on a SATA drive so I trust someone who knows what to do next will be able to elucidate.

  Fruit Bat /\0/\ 19:20 11 Nov 05

Master and Slave

Remeber since it's serial you can only have one device per SATA port/cable so SATA drives don't have jumpers. On the Motherboard SATA1 Port is for the primary device, SATA2 port is for the secondary device etc.

SATA controller driver

Your Motherboard or SATA controller card requires a driver to work properly. If you did not get a Floppy Disk with the SATA driver included with your Motherboard you will have to make one. The SATA drivers can be located on the installation CD that came with your Motherboard or preferably, download the latest SATA controller drivers from the manufacturers site. Once you have located the drivers copy them to a formatted floppy disk. Make sure they are in the root directory i.e. not contained within any folders.

BIOS settings

When you turn on the PC hit the Delete key when prompted and you will enter the BIOS (Basic Input Output System). Here you set the first boot device to be the CDROM drive, the option is usually found under the Advanced Options section but this depends on your BIOS and you may have to look around for it. Once you have done this save and exit.

Installing the SATA controller driver

Once you have set the PC to boot from the CD make sure the XP CD is in the CD drive and start the installation as per usual. Within the first minute or so of the installation Windows will prompt you to press F6 to install RAID or SCSI drivers, do this. Windows will continue to install then ask you to locate the driver. now with the floppy disk created earlier in drive A: select the driver and hit Enter.

With the SATA drivers installed you can now continue the Windows installation as usual.

This thread is now locked and can not be replied to.

Amazon Fire HD 8 review: A brilliant combination of function and value – with one massive caveat

1995-2015: How technology has changed the world in 20 years

How to create an introvert-friendly workplace

Apple Watch 2 review | Apple Watch Series 2 review: New Apple Watch is faster, brighter, water-resit…