XP Pro refuses to install to SATA HDD's

  Chegs ® 13:08 24 Jul 03
Locked

I have been trying unsuccessfully to install XP into my hdd's.I have a "normal" IDE (Maxtor 7200 HDD)that has simply become to full,and I added two 120GB SATA drives.As there is loads of unused space on them,I decided to install XP into the SATA drives,and can then remove the IDE drive only I get various errors,NT... is missing so SETUP cannot continue,even the CLOCK in BIOS is wrong,so change it and SETUP will continue,only the BIOS clock is set correctly,and I was able to reinstall XP to the IDE drive,so these errors it keeps producing are nonsense(especially the clock error)I was thinking of trying to put 98se in instead,only the drives are all NTFS,so I would have to find storage for some very large files(10+gb videos,etc)then convert the SATA drives to FAT file system,and I dont want to work around the file relocation/format to find 98se throwing up more strange errors.I had a read round the net and it seems to be a common problem,but no-one has mentioned use of a Gigabyte(mine's a 7VAXP Ultra) board,only Asus boards.

  Chegs ® 16:13 24 Jul 03

>

  powerless 19:29 24 Jul 03

Have you installed the drivers on setup?

Press F6 as the prompt commands you ;-))))))0

  Chegs ® 19:47 24 Jul 03

Yes,I followed the instructions in the book which state....


Please find the serial ATA controller drivers files under the CD title


D:\Other\Sil\Si3112r\3112r---->for RAID configuration

or

D:\Other\Sil\Si3112\Si3112------>for Base configuration


When install Windows 2000 or XP from HDD's in serial ATA controller,press F6 as Win2000 or XP boots up,then supply serial ATA controller driver by this floppy disk

Which I took to mean,put them on a floppy,load XP install disc,select Advanced install option,to allow me to specify where it installs,then press F6 during the install,and it accepts the driver floppy,as XP has it highlighted during install,but then when it gets to "Installing Windows" it reports as unable to continue for an assortment of errors,one of which is my mobo clock is displaying the wrong time!

  polar_king 19:52 24 Jul 03

you can install the sata drivers from within windows, but only in this way...
load the sata drivers into windows BEFORE connecting the sata drives
then restart for drivers to take effect
power down, install sata drives, leaving ide drive in place for now
new hardware found should appear then you can format new drives and be disappointed at the new bottleneck somewhere else in the system

this guide curtesy of serial ata quick users guide supplied with my sata mb msi kt4 ultra

but much easier to catch F6 on new installation, as powerless recommends.
after you press F6 it will seem like it ignored you, but xp will stop and ask for raid drivers,
tip, after the xp disk has started doing its stuff, shove the floppy in readysaves time and installs from auto...have fun,, ps it took me hours too lol

  Rayuk 19:59 24 Jul 03

Looking at your first post you say you have loads of space on these hard drives.
How are you trying to instal win on both drives,if you are going to use both as raid0 on sata you will have to start from scratch.

  Chegs ® 20:03 24 Jul 03

But I get XP to accept the driver floppy,it goes right up to where "Installing Windows" and then insists on Setup ceasing as MAIN ERROR usually CLOCK set incorrectly.I had to allow XP to reinstall itself over my present XP,as it simply will NOT continue to load to the SATA drives.I thought perhaps it might be due to my using Partition Magic to partition the 240GB's that XP says it was(not 2 x 120GB's)from IDE drive,but I removed ALL its partitions,I removed the IDE hdd,and each time I get the install STOPPING and displaying various errors.(but usually the clock time)

  Chegs ® 22:09 24 Jul 03

?

  temp003 05:52 25 Jul 03

A few things to try.

Go into your CMOS settings, and load optimised defaults or even defaults. This makes sure your system is not overclocked.

Still in CMOS settings, go to:

(1) Advanced BIOS Features, set the SATA/ RAID/ SCSI Boot Order to "SATA"

(2) Advanced BIOS Featurs, set the relevant Boot Device to "SCSI", and not hdd 0-3 (e.g. First Boot Device: floppy, Second: CDROM, Third: SCSI)

(3) Integrated Peripherals, Onboard H/W Serial ATA, set to "Enabled"

(4) Integrated Peripherals, Serial ATA function, set it to "RAID" if you want to use RAID, but set to "BASE" if you don't want RAID.

The Silicon Image SATA driver on the floppy after pressing F6 during XP Setup should be the right driver (either BASE or RAID whichever is the one selected in BIOS).

Save Settings and Exit.

If you've done all that, and it still doesn't work, try changing your RAM modules, or if you have more than 1 module, leave only one in and remove the rest.

  temp003 05:55 25 Jul 03

Sorry, the second paragraph in my last post should read "load optimised defaults or even fail-safe defaults".

  Jean-Luc Picard 10:19 25 Jul 03

I had numerous problems attempting to run my SATA hard disk. The only way I could get it to run was by loading the operating system on a small boot partition on my 120gb hard disk.

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

These are the Best Christmas Ads and Studio Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…