XP Home setup cannot get rid of choice at boot

  reburner57 11:24 17 Apr 04
Locked

After deleting a load of stuff from the prefetch folder defrag wouldn't run because it said a file wasn't there. No probs I thought, I'll just reinstall XP and the missing file will magically reappear.

Upon reinstalling XP I got to the stage where it asked to reboot and upon reboot got the choice of Windows XP Media Center Edition or Windows Xp setup (default) I chose setup but the machine just hung on the Starting Windows setup screen.

It works Ok (and defrags Ok) if I choose Windows Media Center edition but I don't want to have to select this every time I boot.

Can anyone help ????

  MichelleC 13:12 17 Apr 04

May need to edit boot.ini file. You can view contents in Folder options/view/ and uncheck 'hide protected system files...' If you view in notepad and post here someone can help.

  Legolas 13:22 17 Apr 04

You can edit your boot up file by right clicking on the 'My Computer' icon on your desktop click properties then 'Advanced' then click on the settings button for 'Startup and Recovery' The drop down box at the top of the screen that opens will list your operating systems choose 'Edit' and delete the operating system you want rid of.

A word of warning make sure you delete the correct one or you will not be able to access that system.

  Cuddles 13:23 17 Apr 04

I would not advise anyone to uncheck this option as it can make your os inoperable.

  Legolas 14:17 17 Apr 04

Cuddles I have done this often and as long as you delete the correct one one there is no problem.

  Legolas 14:19 17 Apr 04

Sorry Cuddles I think you were responding to MichelleC post ;-)

  temp003 14:49 17 Apr 04

Unticking the box for "Hide protected operating system files" will not make OS inoperable. It just shows certain files in Explorer otherwise not seen. After doing what you need to do, you can revert to old setting if you like. I always have them shown.

reburner57:

You need to set XP Media Centre as the default OS, then as Legolas says, delete the reference to the other OS.

Right click My Computer, Properties, Advanced, Startup and Recovery, Settings. System Startup - Default Operating system, click the drop down list and you should see XP Media Centre Edition. Select that. Click as many OK as you need to exit the window.

Then get back into Startup and Recovery Settings. Click Edit.

This opens the c:\boot.ini file in Notepad. Under the section [operating systems], delete the line (should be the first line) that says something like:

C:\$WIN_NT$.~BT\bootsect.dat="Microsoft Windows XP Setup"

As long as it refers to XP SETUP, that's the line to delete. Just delete that line. That's the only change to make.

Then click File, Save.

Then click OK, OK until you exit window.

Restart.

If you go straight into XP without boot menu, it's worked.

Then go to C drive, find the folder $WIN_NT$.~BT. Delete it. This is the folder where temporary XP installation files are stored. Had you proceeded with the installation, this folder would have been deleted after the complete installation. You don't need it now.

  reburner57 17:15 17 Apr 04

thanks all for your contributions temp003 your instructions were spot on and resolved the problem. Cheers

This thread is now locked and can not be replied to.

What is Amazon Go and will it come to the UK? The store without checkouts or queues

1995-2015: How technology has changed the world in 20 years

Hands-on with the Star Wars fighting drones you can fly yourself

iPhone 9 and beyond: 32 amazing future smartphone developments - graphene, supercapacitor…