XP Home can't see 3Com 56k modem

My internal modem decided to stop working a few days ago, so I borrowed my daughters "3Com US Robotics 56k Faxmodem" and tried adding it to my system.

The drivers that came with it are for Windows 95/98.

When I try to add it as a new modem, I just get a message saying that the system can't see it. Just before this message comes up one or two of the lights on the front flash on/off.

I have a 33.6k modem which gets picked up with no problems, so I'm fairly certain that the port and cable are okay.

Any ideas?

Thanks in advance


I thought that XP was supposed to have drivers for virtually everything?

Any ideas?

  Pikachu 15:16 21 May 03

XP would not have drivers for everything - I had the same problem when I upgraded to XP and had to buy another modem and new Anti-Virus software that was XP Compatible :( as I could not find drivers for the old modem. If you visit the manufacters website they may have an update.

  Allan-263226 15:36 21 May 03

It looks as if the problem could be due to the power supply. The original wouldn't work, so I found another 9V AC power block and tried this instead.

According to US Robotics, if you don't use the power block supplied with the modem then this can cause the problems I have been getting. It would appear that the modem needs 9.2V and not 9V.

A new power block will cost me £20 + vat + postage. Does anybody know where I can get hold of a second hand one? A new modem would only be about £35.

This thread is now locked and can not be replied to.

Sniper Elite 4 review: Headshotting Nazis has never felt so good

1995-2015: How technology has changed the world in 20 years

The Fresh New Fonts of 2017

WWDC 2017 dates: How to get WWDC 2017 tickets, when is WWDC 2017 and more details announced