WPA needs SSID Broadcast Enabled to Work

  mulligan 20:13 04 May 07
Locked

I have just changed my Netgear DG834G wireless encryption from WEP to WPA but was surprised to find that it would only work with SSID broadcast enabled (network not found otherwise). Win XP and Netgear WG311 802.11g Wireless PCI Card. Is it better to have WPA with SSID broadcast enabled or WEP with SSID broadcast disabled? Is this a problem?

  postie24 20:17 04 May 07

Use the wpa encryption,just change the name of the SSID.

  mulligan 20:21 04 May 07

I have changed the name of the SSID. Does it matter that its being broadcast?

  postie24 20:23 04 May 07

No it is fine,just as long as the name you chose has nothing in it to let anyone know who your ISP is

  mulligan 20:26 04 May 07

Thanks. Will leave thread open a bit longer in case anyone else has had this happen.

  woodchip 20:40 04 May 07

No Idea Why that Happens, I use a 3Com WPA and brodcast SSID disabled

  Dipso 00:35 05 May 07

Do you have the latest firmware for the Netgear? I have a Netgear PCI card and that worked OK with broadcast SSID disabled.

Did you try entering the WPA passkey into the Netgear wireless cards utility even though you couldn't "see" the wireless network?

  mulligan 18:13 05 May 07

Dipso, my Netgear DG834G is V2 and has firmware 1.04.01. There are 4 newer firmware versions, the latest for UK is 3.0.1.31 but I am not aware that the WPA/SSID broadcast issue was a bug fix. I am using Windows XP wireless setup software rather than the Netgear utility as I have found it more reliable. When I set it up I just entered the SSID and passkey even though windows couldn't "see" the wireless network. Is it worth risking a firmware upgrade even though everything else is working?

  fitshase 22:27 05 May 07

"Is it worth risking a firmware upgrade even though everything else is working?"

As long as you follow the instructions, nothing should be risky. After all, if your router is still in warranty, you can get support from Netgear if anything goes wrong.

I've updated the firmware on mine a few times and not hit any problems - it is always best to have the latest firmware anyway. I found the wireless range increased when I upgraded (which was a bonus!).

  mulligan 22:42 05 May 07

Thanks fitshase. Updated to 3.0.1.31 and wireless network now working with WPA even with SSID broadcast disabled. Must have been a problem with 1.04.01.

  Dipso 22:49 05 May 07

Glad you got it working mulligan. The version you had was pretty old. I don't know if Netgear will be providing any further fw upgrades for the v2 now that there's a v3. My only advice would be to download the recovery utility just in case an upgrade fails and when performing the upgrade always disconnect the router from the phone line as interuptions can cause it to fail.

This thread is now locked and can not be replied to.

Sniper Elite 4 review: Headshotting Nazis has never felt so good

1995-2015: How technology has changed the world in 20 years

The Fresh New Fonts of 2017

WWDC 2017 dates: How to get WWDC 2017 tickets, when is WWDC 2017 and more details announced