Word problem from My Documents

  paul_allard 15:39 08 Aug 03
Locked

When I try to open a document within My Documents, I get the following message :

The document name or path is not valid. Try these suggestions. Check the file permissions for the document or drive. Use the File / Open box to open the document. (C:\Documents.doc) and an OK button.

When I OK, the following box appears :

The document name or path is not valid. Try one or more of the following. Check the path to make sure it is typed correctly. On the File menu, click Open. Search for the file using the dialog box (Settings\Paul\My)and an OK button.

When I OK, the following box appears :

The document name or path is not valid. Try one or more of the following. Check the path to make sure it is typed correctly. On the File menu, click Open. Search for the file using the dialog box (Documents\NameofDocument)and an OK button.

When I OK, Word opens and I then use File / Open.

However I encounter no problems when I want to open a document within Word.

So the problem only exists within My Documents. Any ideas about how I can cure this annoying problem ?

I'm running Office 2000 / Word 2000 within Windows XP

  VoG II 16:04 08 Aug 03
  Jester2K II 16:07 08 Aug 03

http: // support .microsoft .com/default.aspx?scid=kb;en-us;q224016

Copy to your browser and then remove the spaces...

  Jester2K II 16:07 08 Aug 03

VoG!!! - why you..............................

  paul_allard 18:50 08 Aug 03

None of the causes listed on the support site seem to be relevant since it happens with every single document in My Documents.

  VoG II 18:53 08 Aug 03

Have you tried Detect and Repair from the Help menu in Word?

  temp003 07:02 09 Aug 03

The shortcut paths in My Documents are obviously right. The symptoms suggest that when Word is trying to open a document, it is not reading the complete path, but stopping at the spaces.

So instead of reading ?C:\Documents and Settings\Paul\My Documents\abc xyz.doc?, it stops at ?C:\Documents?, and then may or may not go on to look for C:\and, and then C:\Settings\Paul\abc.

One or more of the settings for Word?s shell open command are wrong.

VoG?s suggestion of a Repair of Word should cure it, and is probably simplest.

If you want to check these settings manually, you can close Word. Then go to Folder Options, either from Control Panel or in My Computer (Tools, Folder Options), select the File Types tab. Scroll down to highlight DOC. Click Advanced.

In the Actions box, highlight ?Open?. Then click ?Edit? to the right. Check the following.

In the box for ?Application used to perform action?, put your mouse cursor in the box, and navigate to the end of the path.

The complete path should be:

?C:\Program Files\Microsoft Office\Office\WINWORD.EXE? /n

The path in quotation marks should be the right path to winword.exe on your computer (which may be different from mine). This should not be the problem.

Look at what?s in the end.

It should be just ?C:\?\winword.exe? /n

If you have /n %1 at the end, or /n ?%1? at the end, delete the %1 or ?%1?.

Then check that the box for ?Use DDE? is ticked.

Then check that in the box for DDE message, the words are:

[REM _DDE_Direct][FileOpen("%1")]

Make sure that there are Quotation Marks around %1. If it is only %1, add quotation marks around %1.

Then click OK, OK, Close.

Go back into Folder Options, File types,..., Open, Edit (same as before).

See if the changes you have just made have been retained. If so, click Cancel and so on to exit Folder Options again, then try to open a Word document from within My Documents to see if it works.

If the settings you?ve changed are not retained in Folder Options, something in the registry has overridden or are preventing your changes.

The first registry keys to look at (and there are many others to check) would be HKEY Classes Root\ Word.Document.8\shell\Open\command, and shell\Open\ddeexec, but rather than going through the registry, you should try Repair.

If Repair doesn't cure it, post back for registry method.

  temp003 07:11 09 Aug 03

I'm sorry, the text above is a bit of a disaster. Somehow some of my quotation marks have come out as question marks.

I'm sure it's all very clear to you now :o)). This is a real bore.

Hope it comes out all right this time.

In Folder Options,..., Edit, the Application Used to Perform Action should be:

"C:\Program Files\Microsoft Office\Office\winword.exe" /n

If after /n, you see %1, or "%1" at the end of that line, delete the %1 or "%1"

The Use DDE box should be ticked.

The DDE message should be

[REM _DDE_Direct][FileOpen("%1")]

This thread is now locked and can not be replied to.

What is Amazon Go and will it come to the UK? The store without checkouts or queues

1995-2015: How technology has changed the world in 20 years

Hands-on with the Star Wars fighting drones you can fly yourself

iPhone 9 and beyond: 32 amazing future smartphone developments - graphene, supercapacitor…