Word 2007 spell check not working correctly

  wildrover 17:46 17 Aug 09
Locked

hi. I can't get the word 2007 spellchecker to work in an important document I am editing. If i open a new document it works fine but in the document I am editing at the moment it will not recognise misspelt words and does not underline them as I type. I've tried to copy and paste the text into a new document but it takes the problem with it. The peculiar thing is that there is a tick next to 'do not chech spelling' in the language dialogue but if I clear it, it just returns and goes back to not checking again. Any suggestions?

  bremner 17:51 17 Aug 09

Is this a document you have brought from elsewhere using a template?

  wildrover 18:35 17 Aug 09

It isn't, it originated on my machine, but it has been reviewed on another. It has been opened and edited on at least two computers.

  BRYNIT 19:17 17 Aug 09

It could be the spelling grammar checker is switched off. Look at the status bar very bottom you should Pages, words and an icon that looks like a pen writing on a book, if you do not see this the spelling and grammar check has been switched off. If you right click at the bottom and put a tick against spelling and grammar.

  wildrover 08:45 18 Aug 09

Thanks. The icon is there but when I right click it 'Spelling and Grammer Check' is ticked. To the right hand side of 'Spelling and Grammer Check' it says 'no errors' but I know that there are.

  BRYNIT 20:11 18 Aug 09

It sound as though the document settings may be slightly different to the original template. Have you checked that the language settings are correct.

Also a quick search of the web found this click here don't know if it will work.

  wildrover 21:52 18 Aug 09

Yes, the language settings are all OK. Everything is ticked that should be and not ticked that shouldn't. I tried your click here but did not have a disabled item, so that came to a dead end unfortunately.
It has got stranger though. As I had the document open to do your 'click here' I typed a couple of letters at the beginning of the document and the spell check works fine there. It chnages part way through a paragraph on page 16 of a 21 page document. All language/proofing settings appear the same in the different sections of the document but the spellcheck isn't working on the last few pages! All the text that is not being spell checked has only been on this machine, i.e. not reviewed on another computer.
I have also noticed that when I opened the document, all earlier proofing (like text marked 'ignore') has gone and it is showing 'proofing errors' at the bottom.

  wildrover 22:23 18 Aug 09

I made a copy of the whole file and the spell check problem was still there in the copy. So I cut the text from the point that it was 'corrupt' then put in a return and pasted the text back. Deleted the return (to put the paragraph back together) and spell check is working again! Also typed new text at the end of the document and spelling is working fine. This did not work with a simple cut and paste. The return/delete seemed to do the trick.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…