WMP won't play AVI files.

  ened 18:41 10 Jul 08
Locked

Weird problem this.

For no apparent reason whatsoever WMP has nearly stopped playing avi files.

I am using Vista ultimate(64).

It opens on the library and if I try to play an avi file it keeps the library screen but starts playing the audio. If I switch to 'Now Playing' I simply get the visualisations as if it is playing a music file.

However if I open a folder and double click on a WMV it will play and so will avi files after.

This all started when I noticed that the icon in the Quick Launch Bar, instead of being for WMP, was Internet Explorer. I deleted it and dragged the correct item down. All was well but to be on the safe side I went back a few days with System Restore. The problem then started and has continued even though I undid the restore.

Any suggestions will be kindly appreciated.

  grey george 20:09 10 Jul 08

You could remove and then re-install wmp.

  Zeppelyn 21:49 10 Jul 08

As I understand it WMP does not play avi files by default, it needs a codec. Im using Vista Ultimate 64 too and this from Xvid works fine for me witn WMP.
click here

  Tim1964 23:28 10 Jul 08

I'm getting similar problem with WMP 11 too. It always played AVIs fine but now it has an annoying habit of popping up a message saying

"Windows Media Player encountered a problem while playing the file. For additional assistance, click Web Help."

If I click on the X to close the message and then click PLAY the file opens/plays fine ??

(Vista Basic)

  ened 06:29 11 Jul 08

grey george How doeas one do that in Vista?

Zeppelyn I already have the Klite package installed and all has been well for over 6 months.

Tim1964 As you say: a similar problem. Are you aware of anything you might have done (no matter how insignificant) prior to the problem?

  ened 13:08 11 Jul 08

I have now determined that under certain circumstances Vista fails to realise that I have the correct codec.

Does anyone have some advice on how to resolve this?

  Stuartli 13:14 11 Jul 08

I use K-Lite, but perhaps a change of codecs pack may help. See:

click here

By the way, you do have all file types Enabled in File Types (WMP>Tools>Options>File Types)?

  ened 16:19 11 Jul 08

In your link which is the download I need? Under Klite there is a Vista package; is that the one you are suggesting?

Also, for some reason I don't have the option of 'file types' in options in WMP.

  Stuartli 18:04 11 Jul 08

The link should take you to the Multimedia Codec 8.3 download from M5studio - this is a different offering to the K-Lite version.

It would be best to uninstall the K-Lite version you have before installing the above, if you do decide to try an alternative.

Can't understand why you don't have a File Types tab in Windows Media Player.

  grey george 18:13 11 Jul 08

uninstall wmp from vista Arr? You have to open the control panel then select the uninstall programmes option. Then on the left is an option to show updates select this. you will now see all the updates, so you have to select those which relate to wmp11. Then go to the update site and re-download it. There is an option in wmp to download codecs automaticley is this ticked, it's in the more options tab.

  sinbads 19:11 11 Jul 08

There is no option in vista to enable file types in WMP11 /options/file types, think there is in XP.

For vista,

To change media player file type associations in Vista: Go to Start, then Default Programs. Choose Set Your Default Programs. Select Windows Media Player, then ‘Choose defaults for this program’. As with xp select all

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…