Wireless speed halved for no apparent reason

  Squeals 22:42 30 May 06

Am using XP Home SP2 on Evesham desktop, Belkin PCI 802.11g 125g card (7001) with Belkin ADSL modem/router (F5D7633) with High Speed Mode enabled and WPA (checked no-one else is sharing connection in router diagnostics).

For no reason that I can ascertain my connection speed has suddenly halved from around 100Mbps to a max of 54Mbps. Have not personally changed router or PC settings (router is passworded, but possible daughter/wife could have changed PC without me or them knowing), not moved either router or PC. So why could it have dropped speed and what can I check?

Should I try changing channels (currently 11) and if so how do I do this (ie other than using the drop down menu in router page)?

Any assistance VERY greatfully received.



  ade.h 23:24 30 May 06

The drop down menu *is* how you change the channel. WZC will pick up the change automatically. I'm not at all sure that it's the cause, though.

  Squeals 00:04 31 May 06

Thanks Ade

Two (probably dumb questions) what is WZC and what is the reason for different channels (assumed they were like on a radio - to allow fine tuning of connection).....


  dms05 12:39 31 May 06

WZC is a Windows Utility that helps control your wireless network (Wireless Zero Configuration). That's assuming you have selected Windows to control your WiFi rather than software supplied with your router (use Windows if the latter is the case).

Can you see any other Wireless Networks that could be interfering? Changing Channel might improve things. Try Ch 1 through to 10 and see if it helps.

  LivEviL 18:12 31 May 06

any luck? just wondered...

  Squeals 19:33 31 May 06

Thanks for info, have enabled WZC and disabled Belkin utility (also updated all drivers) and still no joy. Will try channels later on (need to try and do some work!!). Will keep you posted but please let me have any other thoughts as they occur.

2morrow will try a hardwire to the router and see if that makes any difference. Failing that have to assume router or card is failing and need to replace (have not seen encouraging postings about the Belkin kit in general so might try Netgear next time......).

Thanks again


  ade.h 19:54 31 May 06

"...have not seen encouraging postings about the Belkin kit in general..."

I don't mean this as a dig at you, but generally speaking, most of those issues that you have seen are user error. Like most networking problems, in fact. A small percentage of problems are down to incompatability of hardware/systems/software and an even smaller percentage is caused by faulty equipment. Of the issues that occur suddenly after a period of time (fairly unusual, this) there is a roughly equal split between equipment failure, environmental change and user error.

  Squeals 17:37 01 Jun 06

Apologies if my comments seemed somewhat one sided. I am quite sure that, as with most IT problems, somewhere at the root of the issue there lies a user/abuser!! I guess what I was more trying to state was that perhaps the Belkin equipment is less fault tolerant or easier to set up incorrectly.

Getting back to the original problem - I have met with half success. Having changed the channel on the router to 1 (from 11) I seemed to have suddenly go 125MBps speed showing (according to the task tray icon), BUT still only 54MBps from teh PCI card. I've got a second card so will try swapping them, alternatively may just do a hard reset on the router/reinstall the card and see how that fares.

Will keep you posted.

Thanks all for keeping with me on this one.....


  ade.h 18:01 01 Jun 06

It seems to me that all the disparate "standards" that have been created prior to 802.11n's eventual ratification later this year (long time coming; the new standard was originally mooted as long ago as 2000!) have not been entirely smooth. While Airgo's latest development remains up in the air somehwat, the other manufacturers have had to deal with their impatience as best they can. Their efforts have been pretty good by and large, but there is always more room for glitches with such things. Me? I have stayed firmly with 11g! That said, I have seen/heard about other people's boosted setups (Belkin included) that work fine. One of this forum's regular contributors has actually mixed a Belkin Pre-n router with a Linksys adapter and it works perfectly!

This thread is now locked and can not be replied to.

Nintendo Switch (Nintendo NX) release date, price, specs and preview trailer: Codename NX console…

1995-2015: How technology has changed the world in 20 years

8 things designers (and brands) need to know about the modern woman

How to speed up a slow Mac: 19 great tips to make an iMac, MacBook or Mac mini run faster | Speed…