Wireless Problem with DrayTek Router

  WightRob 20:44 PM 15 Nov 11

I recently changed from a D-Link router to a DrayTek Vigor 2830Vn. On the LAN I have a desktop PC running XP Home and a laptop running Vista Home Premium. With the D-Link I was able to see the shared folders on the laptop from the desktop if the laptop was connected wirelessly or with a cable. With the DrayTek I can only see the shared folders when the laptop is connected with a cable. All other network functions including web access work from the laptop with a wireless connection. DrayTek tell me that there is no setting on the router that will affect this but I am not so sure. Any ideas?

  mgmcc 21:56 PM 16 Nov 11

A "wireless" connection should simply emulate a wired ethernet connection and shouldn't make any difference as far as File & Printer Sharing is concerned. However, if you had previously configured a software firewall to allow access to a particular IP address, or range of addresses, these details may have changed with the different router.

  WightRob 11:10 AM 03 Dec 11

Thanks for your reply, I agree that the wireless connection should only emulate the wired connection. However, in this case, in practice there is a difference. I have tried disabling the computer firewalls and the router firewall by to no avail. Does anyone else have any suggestions?

  difarn 13:38 PM 03 Dec 11

Have you enabled file and printer sharing? on your wireless network?

  WightRob 13:03 PM 04 Dec 11

That was a good thing to check, but yes it is enabled. I have just connected the Dlink router as a wired link to the DrayTek hub i.e. the Dlink is connected to the DrayTek via a single ethernet cable and everything else on the LAN and the phone link is connected to the DrayTek. If I connect the laptop directly to the DrayTek wireless connection the problem persists. If I connect the laptop to the Dlink wireless connection then all the links are OK. DrayTek still insist that the problem does not lay in their router but to me this shows that it probably does. Any comments?

  difarn 16:58 PM 04 Dec 11

Puzzling one this - more things to try if you haven't already done so:-

Are both devices in the same Workgroup? XP machines usually use MS Home and Vista Workgroup? They need to be the same.

Does your XP machine see the Vista machine?

Do you have file and printer sharing enabled on BOTH PC's

Change network settings from Public to Private

Are all of your drivers up to date?

  WightRob 22:23 PM 08 Dec 11

Thanks difarn.

In answer to your queries: 1 Yes, the workgroup is the same on all machines. 2 The XP machine sees the Vista machine and vice versa with cable but they do not see each other when the Vista machine is wireless. 3 File and printer sharing is enabled on all machines. 4 The network is Private. 5 As far as I can see, all the drivers are up to date.

These were all good suggestions but unfortunately have not solved the problem. I am currently on to Novatech where I bought the router - they offer unlimited tech support - so fingers crossed.

  difarn 23:26 PM 08 Dec 11

Just been reading this. It would appear that Vista uses the Public Folder for file sharing. If you read the section " Differences in File and Printer Sharing in Windows Vista" it may shed some light ont he problem.


This thread is now locked and can not be replied to.

How to watch Rugby World Cup 2015 online: Watch live, catch up on-demand & stream the 2015 Rugby…

1995-2015: How technology has changed the world in 20 years

How to watch Adobe Max 2015: See Adobe unveil new Creative Cloud features for Photoshop,…

Live Photo tips: How to take Live Photos on the iPhone 6s, how to view, share, edit and find Live…