Wireless N only getting 54mbps

  choccy31 01 Jun 11
Locked

Hi there,

I got a new Dell desktop - XPS7100 in April with Wireless N Wlan card and everything was running fine speed wise however for last two weeks I am suddenly only being able to get 54mbps on my wi-fi connection.

I have installed drivers to latest etc but still cannot get back to the speeds I should be getting on my 50Meg BB.

Nothing has changed with the router or anything so am at a loss as to why this has suddenly happened.

Help please!

  Secret-Squirrel 01 Jun 11

You can get that behaviour when a wireless G (54mbps) client connects to an N router. When that happens most routers fall back to the the speed of the slowest client.

Does that explain what's happened to you? If you're not aware of any other wireless devices then check the relevant section in your router that shows currently connected wireless clients. Not all routers display that info though.

  choccy31 01 Jun 11

Hi,

Thanks for reply.

Only thing I know that might be new connection is my brother got an ipad2?!

  Secret-Squirrel 01 Jun 11

The iPad2 is wireless-N compatible so I don't think it's that.

Where are you getting the 54mbps connection speed info from and what speed did it used to report?

  choccy31 01 Jun 11

Hi,

The network connection status says wireless n signal strength good or excellant etc and then on status says 54mbps as the speed.

Used to be around 300 odd when I was using April - Mid May.

No idea why suddenly the change. :-(

  Secret-Squirrel 01 Jun 11

Thanks for that info.

Providing that you're sure all users of the wireless network are using N adapters then here are some things to try with your router:

1) The simplest and quickest potential fix is to turn the router off for a minute then turn it back on.

2) The reduction in performance could be due to some nearby interference and changing the wireless channel number usually helps in those situations.

Log into your router and go to its wireless section. Select a channel number that's as far away as possible to its current one. If it's set to "Auto" then pick a channel number at random, and if no improvement is seen, change it to another.

3) By default, most routers are configured in "mixed mode" where they're able to communicate with wireless B, G , and N clients. If its just you and your brother using the router wirelessly then try this:

Back in your router's wireless section, see if you can set it to "N-only" mode. That'll force it to always use up to 300mbps N speeds but devices with older, B & G, adapters won't be able to connect.

If none of that helps then reply with what the router's Wireless security is currently set to - some examples are "WPA2 AES", "WPA2 TKIP", "WPA" or "WEP", etc.

  choccy31 01 Jun 11

Hi

Tonight went into router and changed the security settings and updated the firmware and seems to have made a difference now.

Currently I'm now showing 130.Mbps on mine and my brothers ipad 2 was zooming on the net earlier as is my mobile which can be closer to the router signal then my desktop.

I do have a wireless N USB which i could use in future to get closer to signal but think will be ok for now.

Thanks for all your help :-)

Advertisement

This thread is now locked and can not be replied to.

Windows 10 Home vs Windows 10 Pro comparison: Here are the extra features you get in the Pro version

Behind the scenes at Silverstone, the 70th British Grand Prix: Hisense starts UK push with Red…

How Found created this skateboard, bike and parkour stunts-laden, single-take car ad

Apple Pay UK launch date, UK user guide and participating UK banks | Apple Pay to launch in UK on 1?…

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message