Wireless Mouse problem

  ventanas 16:47 28 Feb 06
Locked

Just bought a Labtec wireless mouse for use in the office and I can't get it to work. The cursor appears, but won't move.
I have gone through the motions of removing all existing pointing devices (there is also a separate tablet and mouse attached to this machine) and it still won't work.
It comes with both USB and PS2 options for connection and I have tried both. (Does it matter which one I use?) The receiver is detected when I try the USB connection.

I have also tried it on another machine and it won't work there either, so perhaps it could be faulty.

It's a bit worrying because I have also bought one for my home machine, and that also has a tablet attached to it.

Grateful for any advice.

  anskyber 16:53 28 Feb 06

Sorry if this is insulting I do not mean it to be but my Logitech needed the mouse and the receiver to be linked by pressing buttons under each.

  ventanas 16:58 28 Feb 06

Not insulting at all, this could easily be overlooked. This one also has buttons on each and I have pressed both of them many times.

  Hilly Heatseeka 17:02 28 Feb 06

Their customer service number is 0207 309 0127

Or feel free to call me on
0870 730 0622

Kind Regards
Daniel Hill

  woodchip 17:02 28 Feb 06

You have to do it in the right order, I think on the Receiver first then the mouse.

Sorry about this, but you have put batteries in the right way round!!!!

  ventanas 17:03 28 Feb 06

but this is a Labtec. Beginning to wish I'd bought a Logitec.

Thanks anyway.

  woodchip 17:05 28 Feb 06

PS I just got a Wireless Optical for my Laptop, a Sigma from MAKRO £10 plus vat

Also check device Manager to see that the drivers are loaded, there should not be any yellow icons

  Hilly Heatseeka 17:06 28 Feb 06
  ventanas 17:06 28 Feb 06

Hi Woody, yep, they are the right way round, and the receiver was pressed first. I've runout of ideas, and as it won't work on two machines I think it's going back.

I'll see what happens at home with the other one, but I won't get around to that till the weekend. Got to pull it out from the wall to get behind it.

  ventanas 17:07 28 Feb 06

I'm very grateful. I will ring them tomorrow.

Thanks very much.

  ventanas 11:51 01 Mar 06

Sorted. It was my fault. Waiting too long before pressing the button on the mouse. Did it more or less simultaneously and it worked.

Thanks for the help.

This thread is now locked and can not be replied to.

Surface Pro 5 News - release date, UK price, features, specs

Gear VR vs. Daydream: Which delivers the best VR experience?

iPad Pro 12.9 vs Surface Pro 5