Wireless connection - Laptop to Desktop.

  silkylady 10:25 20 May 05

Hi, I have a 3Com wireless access point and have managed to set up a connection between both computers the only problem is I cannot get access to the internet at all. I haven't much tech. knowledge but have followed the instruction (such as they are) which is provided and just cannot understand why this problem is occurring.
Can anyone just run through how I should have my pc's connected? I have an access point, pcia? card adapter, usb network adapter, 2 ethernet cables. In the desktop which is connected to blueyonder broadband via a surfboard cable modem there is a realtek card and a netgear card and I have intel centrino wireless capabililty on my laptop.

Any suggestions would be so helpful, please? I have now got myself very muddled trying various different things and have totally messed it up now.

Thanks in advance

  John-259217 11:25 20 May 05

Have you enabled Internet Connection Sharing on your desktop computer?

If you ran the network set-up wizard and selected the right option it may well have done this for you for some more information goto Windows help and support centre (from start menu) and type ICS.

How do you have the equipment you listed connected at the moment?

The Centrino laptop will connect wirelessly to the access point which will need to be connected to the desktop.

It sounds like you may have more kit than you need -- making things more confusing.

  silkylady 11:52 20 May 05

It appears I have the access point connected to the desktop (netgear card usb port) via ethernet cable, the modem connected to the desktop via ethernet (realtek card usb port). I haven't got the pc (not pcia, sorry)adapter card or the usb adapter set up in anything at the moment although believe me I have tried, lol. I have ran all the installation discs as per instructions (network wizards etc)and then when no joy just started to try different things (which is where trying out the pc and usb adapter cards came into it) so its a complete mess now and I have no idea how to undo or even which bits to undo!!!

I really need to start from scratch with some info from someone who knows what they are talking about. I probably have got too many bits and bobs but I won the kit in a competition so I'm not complaining, lol.

Thanks for any further info.

  John-259217 13:06 20 May 05

Ok the equipment set-up sounds right, just one further query, are the realtek and netgear adapters for the desktop in the machine or are they USB adapters (it`s not all that important but as you put USB next to them above I wasn`t sure).

I`m afraid the next bit sounds techy, sorry in advance :-}

What we need is the whole set-up of the lan talking on related addresses. Using ICS requires one of the desktop`s adapters to use, this must be the one connected to the access point (the Netgear card). The other desktop adapter will get its address from the modem as decided by your ISP. The access point also has its own address which needs to be the same as above except for the last number eg. This can usually be changed from a set-up page, accessed with your internet browser.

The catch here is that changing one address results in loss of contact with the other piece of equipment so we need to do it in this order :- Access point set to first, then run the network set-up wizard and select the option which says "This computer connects directly to the internet, other computers on my network connect through this one". Make sure you use the option to manually select your internet connection and ensure that only the adapter connected to your modem has a tick. If you want to access the desktops files from your laptop you will need to enable file and printer sharing when asked to do so.

Let the wizard finish then open Control Panel/Network connections. You should see both adapters listed, the realtek (connected to the modem) one may have a small black hand on it indicating that it is a shared connection. Now use your browser and check that you can still connect to the access point. If you can then your nearly there!

All that remains is to make the laptop connect to the access point. If you have already set this up then the laptop may just "find" the access points signal, allow you to connect and automatically assign a suitable address. If this doesn`t happen post back and we`ll deal with it then.

As you may have guessed, the key to success is getting all the correct addresses assigned to the right pieces of equipment then ensuring the right ones are shared. Windows is pretty good at this but where it finds similar adapters which may have different functions at the other end of their cables it sometimes gets confused.

Good luck


  John-259217 14:43 20 May 05

I should also have said disable any firewall software you may have on either or both machines as this will complicate things.

Once you have a working set-up, the firewalls can then be enabled again and correctly configured.

  silkylady 15:08 21 May 05


Sorry for the delay in answering,I managed to mess up the internet connection totally this time,lol,trying something else.

Thanks for this info. I will check it out and let you know if it works. Thanks for taking the time to be so helpful, its appreciated.

  silkylady 15:11 21 May 05

Oh yes, sorry, the adapter cards are in the machine.

  silkylady 16:50 21 May 05

Hi again,

Well I have done as suggested Access point at netgear connection at and the realtek set to automatic assign, run the network wizard etc, but laptop still not connecting to internet/mail, in fact what I forgot to mention is that in my laptop network connections the realtek is down as cable unplugged so when I try to run the network set up wizard on here it just comes up as disconnected. What have I done wrong? I also keep turning the firewall off which seems to automatically turn itself back on.....This is so frustratingly annoying. Have I got the cables set up right? Both modem and access point each have one ethernet cable leading into back of pc to the different network cards. In my network places on the desktop I have two lan connections one the realtek, the other netgear both showing connected but the realtek one is shared. I also have under incoming: incoming connections: no incoming clients (have no idea where that came from!)
Sorry to be such a pain

  John-259217 21:48 21 May 05

Not a pain at all, don`t worry lots of people struggle with networks so your not alone!

Now, everything on the desktop appears correct, the cables are where they should be and the internet connection (on the Realtek) is shared so our next problem is to get the laptop talking to it.

When you look in network connections on the laptop it is only showing details of its own adapters:- so the Realtek with the cable unplugged will be an adapter on the laptop.

It may be the wireless adapter and is showing as unplugged because it is not set up to connect with the access point or it may be a cable adapter built into the laptop.

If it`s the latter then don`t worry about this as we won`t be using it.

What you need to do is switch on the wireless adapter, how you do this will vary, it may simply be disabled in the network connections page or there may be a switch on the laptop case.

When it`s switched on Windows should pop-up a box telling you that one or more wireless networks (your access point) are available and asking you if you want to connect to one.

I`m assuming here that you did not set any wireless security on the access point originally so you should be able to connect without problems.

This is the wireless equivalent of pluging the cable in, hopefully the access point will pass a suitable address to the laptops connection at this point and the set-up wizard will run properly. If it doesn`t then you will need to do it manually from network connections by right clicking the adapter, selecting properties then tcp/ip and typing in a suitable address as follows:- netmask gateway

The firewall turns its self back on because it`s configured to do so as its default behaviour. It will probably need some settings changed to allow unhindered communication over your local network. This is the reason I suggested that you disable it while you set-up your systems - just makes one less obstacle in the way but again don`t worry to about it too much.

Also don`t worry about the incoming connections as that relates to VPN`s (Virtual Private Networks) and won`t affect your LAN (Local Area Network)

There`s often more involved in getting the wireless connection to work properly but try this for now and see how you get on.

Good Luck


  John-259217 01:33 22 May 05

This other thread click here has some more details about wireless configuration which may help you.

If nothing else it shows your not alone having trouble :-)))

  silkylady 08:27 22 May 05

I wish it were so simple.....right in network connections, I have under Lan/high speed internet: Local area connection network cable unplugged which the realtek, a 1394 (whatever that is) connection: connected 1394 net adapter and an Intel connection: connected intel(R)PRO wireless220bg (this I assume IS the wireless connection. Have tried doing as suggested with the realtek but when assigning ip address manually it seems it needs dns address's too?

Obviously something is out, lol.

This thread is now locked and can not be replied to.

Nintendo Switch (Nintendo NX) release date, price, specs and preview trailer: Codename NX console…

1995-2015: How technology has changed the world in 20 years

8 things designers (and brands) need to know about the modern woman

How to speed up a slow Mac: 19 great tips to make an iMac, MacBook or Mac mini run faster | Speed…