Wireless Connection Disconnects after few seconds

  Milner1 22:17 12 May 06

I have recently purchased a BT Voyager 2091 wireless router. Although this gives a perfect connection with my laptop, I can't for the life of me get it to connect smoothly to my Compaq Pressario PC. The PC was purchased late 2003 and runs Windows XP. (The laptop connection works in the same room that the PC is in.)

As a wi-fi connection wasn't integral to the PC, I purchased a Wireless USB adaptor from BT compatible with Windows XP and 802.11g/802.11b wireness networks. When I turn on the computer, the connection seems to fine and I can surf the internet quickly and easily.... however, this state of bliss lasts approximately about 30 seconds, maybe a minute, before the connection suddenly appears to hang and I get a "Cannot Find Server - This Page Cannot be Displayed" message. The only way I can reconnect is to re-boot. This happens each and every time I turn the computer on. We had a computer engineer out recently who was baffled with the problem and took away our adaptor to check there wasn't a problem with that... which he confirmed there wasn't the next day.

Fearing a virus had infested the computer causing this I recovered the Computer to its factory settings using the setup saved on a segregated section of the hard-drive, and reinstalled the Wireless USB Adaptor. However, this was all to no avail though, and I still have this strange problem. Has anyone any ideas? Can anyone help?

  Milner1 22:20 12 May 06

PS, the wireless adapter referred to above is a BT Voyager 1055 - not sure if that will help.

  mgmcc 07:23 13 May 06

It could be a radio reception problem - make sure there is no mobile or cordless phone close to either the Router or the Wireless Adapter (PC). Also, both items should not be close to large metal objects, in particular central heating radiators.

You could try giving the Wireless Adapter a fixed IP address in the same range as that in which the Router operates. This can help in instances where the adapter loses its IP address and the router, being unaware that it has lost it, doesn't automatically renew it.

  Milner1 12:09 13 May 06

Thanks mgmcc,

I've tried the moving mobile and cordless phone connections but that doesn't seem to solve the problem.

Are you able to tell me how I can set the Wireless Adapter a fixed IP address in the same range as that in which the Router operates?

One thing I have recently tried is increasing IBSS Channel Number from 11 to the maximum 14. This seems to prolong the connection from a few seconds to a few minutes. Does this help indicate where the problem might be?

  Milner1 12:19 13 May 06

Another thing that might be useful is that the disconnection tends to occur whenever I try to log on to hotmail. I can surf away for a minute or so, but then trying to log on to hotmail seems to break the connection and I can't log on to any other site until I reboot.

  mgmcc 07:39 14 May 06

<<< how I can set the Wireless Adapter a fixed IP address in the same range... >>>

If you don't know the router's IP address, which should be in the manual, open a Command Prompt window in the PC ("Start > Run", type CMD and click OK) and at the prompt, type:


and press Enter. This will display details of all adapters in the PC. The "Default Gateway" address in the details of your connection to the router will be the router's IP address. From this you know the Subnet (IP address range) that the router operates in - the first three "octets" of the IP address (probably 192.168.0 or 192.168.1 or 192.168.2 etc) must be the same throughout your network. The final "octet" is unique to each device (router, WiFi adapter, ethernet adapter) and is a number between 1 and 254.

Therefore, if your router's address is and it is giving your 'working' PC the address allocate the address to the 'problem' PC.

To allocate a fixed IP address, open the Network Connections folder, right click the Wireless Network Connection and select Properties. Highlight the entry for "Internet Protocol (TCP/IP)" and click the Properties button. In the box that opens, click the button to "Use the following IP address" and enter:

IP address - (a unique address in the same range as the router)

Subnet Mask -

Default Gateway - (the *ROUTER's* IP address)

DNS Server address - (the *ROUTER's* IP address)

<<< the disconnection tends to occur whenever I try to log on to hotmail. >>>

There is a possibility that it could be due to the MTU (Maximum Transmission Unit) setting. See if the router has an MTU setting that you can adjust. The default is normally 1500 so try setting it to 1492 or, if that doesn't help, try 1450.

  dms05 10:11 14 May 06

The last paragraph of mgmcc's excellent reply is very helpul if you are using AOL who have a lower MTU than most. But it may also be applicable in your case.

Are you using the WiFi Utlity that came with your USB stick or XP's WiFi ability. I always use XP to connect to my WiFi. The USB stick utilty will turn off some of XP's features and might cause problems.

  Milner1 07:55 16 May 06

First of all, thanks mgmcc for your post. I tried your suggestion and at first, all seemed fine. The command ipconfig/all brought back IP address details as you stated without me having to manually adjust anything. The Default Server and DNS server were and the IP address was I treid to fnid a MTU setting but without success.

The same disconnection problem occurs after a minute or so, so I tried ipconfig/all. However this time, the command hung for a while before returning "An internal error occure: A device attached to the system is not functioning. Please contact Microsoft Product Support Services for further help. Additional information: Unknown media status code."

Another significant factor is that when I turn off after this, my wireless programs are not responding and I eventually have to press the on/off button for it to turn off. I would have thought this could have been due to something else had it not been for the fact I restored the PC to its factory conditions due to previously thinking this was caused by a virus.

I wonder if dms05 (thank you very much for your response too) is right and that my USB stick is interfering with XP's features causing problems. If so, are you able to advise how to use XP to connect to WiFi. I can't seem to find an internet option that allows this (although I could well be looking in the wrong place.) Could this be that I reset the computer to its original settings and that this computer was purchased in 2003 with XP, and that I need an XP update?

Thanks for all your help on this.

  mgmcc 09:02 16 May 06

It is possible that the USB Wireless Network Adapter is just too "power hungry" for the PC's USB port, causing it to drop the connection and then give you the error about a device not functioning. If you have other USB devices running, such as a printer, scanner etc, shut these down. If the wiFi adapter is connected to a USB hub, connect it directly to a USB port. If it is connected directly to a USB port, using a *POWERED* USB hub might help, as this doesn't draw power directly from the USB port to run the adapter.

Otherwise, it could be down to a faulty USB WiFi adapter and the only way to check that would be to install it in a different computer.

<<< are you able to advise how to use XP to connect to WiFi. >>>

To use the built-in Wireless Networking in XP SP2, you need to enable the "Wireless Zero Configuration" service. Right click "My Computer" and select Manage. In the Computer Management window that opens, click the [+] beside "Services & Applications" to expand it and then select Services. In the right pane, scroll down to Wireless Zero Configuration and double click it. Set the Startup Type to Automatic and click the button to "Start" the service. Click OK and then close the Computer Management window.

If you now go to the Network Connections folder, right click the "Wireless Network Connection" and select Properties, there should be a Wireless Networks tab, select that and tick the box at the top "Use Windows to configure my wireless network settings".

Depending on the software for your USB WiFi adapter, it may take control again when the PC is rebooted so you would have to go through the whole thing again. If this is the case, it might be possible to uninstall all of the adapter's software and then install *only* the adapter's drivers.

To do this, you would plug in the adapter, let Windows find new hardware, opt to install from a specific location and then browse to the drivers on the CD. If the CD runs automatically and tries to install all of the software again, cancel that. You only want the drivers for the adapter - you are probably looking for an .INF file in a Drivers folder on the CD.

  Danoh 20:44 17 May 06

"increasing IBSS Channel Number from 11 to the maximum 14. This seems to prolong the connection from a few seconds to a few minutes."

That would imply that you have neighbouring wireless network signal(s) which is causing interference on yours.
Almost all broadcasted networks I see around me are on channel 11.
Try another channel number such as 5 or 1.

  gadget_boy 14:07 14 Jul 06

hi this is my 1st post, dont know if this thread is still active, are you still having problems?

I have the excactly the same problem with my BT use adapter, did any of these solutions work?

This thread is now locked and can not be replied to.

Nintendo Switch (Nintendo NX) release date, price, specs and preview trailer: Codename NX console…

1995-2015: How technology has changed the world in 20 years

8 things designers (and brands) need to know about the modern woman

How to speed up a slow Mac: 19 great tips to make an iMac, MacBook or Mac mini run faster | Speed…