Wireless Adapter Not Detected On Startup

  Jim.99 19:42 06 Sep 07
Locked

I've recently installed a Belkin-Wireless-G Plus MIMO USB 2.0 Network Adapter-F5D9050 into my Compaq PC. The installation was fairly easy and the adapter works very well. The problem is whenever there is a reboot of the computer, the device manager shows a USB device but says it unknown and there is no driver for it. The light on the adapter remains unlit. If I then unplug and replug the adapter, it works fine. And it works fine until the computer is restarted and it become unknown once again. I don't think I should need to replug it in everytime I restart the computer. Can anyone help?

  STREETWORK 21:09 06 Sep 07

Hi, reboot the PC with the adapter plugged in, go to control panel and then 'add hardware' let windows look for it.

If this does not work uninstall the driver, unplug the adapter, reinstall the software, close down the Pc, plug in the adapter and reboot. Windows should detect the software and load the drivers for it...

  Jim.99 00:14 07 Sep 07

Sorry, didn't get a chance to try your suggestion but my uncle Howie came over with a powered usb hub and we tried that, i.e., keeping power applied to adapter during the power up sequnce. He speculated the problem could have to do with the adapter needing time to boot up before talking to the computer and the computer not waiting long enough for that to occur. The powered hub worksworks! It totally eliminated the problem. Curious if there's another way of accomplishing the same thing without having more wires around the computer.

  Jim.99 19:09 08 Sep 07

The problem has not been resolved. I mean I can go out and get a usb hub and plug it in, but I think there may be someway to fix it in software. does anyone agree?

  Jim.99 21:46 08 Sep 07

I ended up getting a powered USB hub and that solved the problem.

  wher2guv 14:57 23 Nov 07

I have had this problem I did 2 things first go to START / MY COMPUTER / CONTROL PANEL / NETWORK CONNECTIONS Right Click on usb adapter select PROPERTIES Click CONFIGURE Click ADVANCED look for 'CAM when AC Power' make sure it's ENABLED.

Then go into your BIOS settings and enable USB Legacy Devices.

It worked for me.

This thread is now locked and can not be replied to.

Hands-on: Samsung Galaxy S8 review

1995-2015: How technology has changed the world in 20 years

Samsung's beautifully designed Galaxy S8 makes for better VR experiences too

47 iPhone camera tips to help you take better photos