WINXP WONT BOOT on dual boot

Hi
I had this problem when i swapped my hard drive with another for checks.After i connected it again wont boot.
The system is dual boot W2K PRO and WINXP PRO SP2.I have managed to fix the MBR for the W2K partition,but the WINXP's says HAL.DLL is missing.
Tried to copy from CD with no chance as the system recovery console detected some errors and denied access to it.
plz help.cheers

  Nelmon2k 23:13 16 Jan 05

from what i gather quickly its meant to be something to do with the boot.ini being corrupt. See if anything suggested on the microsoft website click here;en-us;330184 is any use

  LastChip 23:16 16 Jan 05

Questions.

Are you saying, the hard drive now in the computer was the original hard drive when these operating systems were installed?

Have you changed anything on the hard drive, other than the MBR?

Are you getting the boot page that allows you to select which system to boot?

If so, does XP start to load and then come up with this error?

Am I correct in thinking there are two or more partitions on this drive and each operating system has its own partition?

  THE TERMINATOR 23:37 16 Jan 05

If XP loads up, but comes up with this error, can you continue or does XP shut down. If it doesn't shut down then put the XP disk in your cd drive, click on RUN and type sfc /scannow,(the gap after sfc was intentional)click OK and windows will replace the missing file....TT

>>nelmon2k,i will try that tomorrow.
>>lastchip,yes they are installed there.i made no changes other than the above.i get the boot page but when i choose XP it says there are errors on the disk and suggests to reinstall the hal.dll.
so XP doesnt load at all.right i have 3 partitions
and each OS in different one.
>>TT,XP doesnt load at all.

NB.W2K is running with no probs.


Guys thank you very much for your time and ideas.
cheers night night.

Nelmon2k>>the link is broken mate.cheers

  THE TERMINATOR 22:22 17 Jan 05

The Nelmon2k link isclick here;en-us;330184 and it might have some ideas to help....TT

  VoG II 22:25 17 Jan 05
  THE TERMINATOR 22:32 17 Jan 05

The link does work but you have to type in 330184 in the search bar to find the info that's on offer....

that is useful guys.
thank you all for your help

I have tried all that above but still cant get it running.Even the recovery console cant detect the WINXP directory.got this error message:
the directory contains unrecoverable or unreadable data.
any more suggestions ?!:)
cheers

This thread is now locked and can not be replied to.

Huawei P10 review

1995-2015: How technology has changed the world in 20 years

An overview: What leading creative agencies are doing to improve diversity

New iPad, iPhone SE & Red iPhone 7 on sale now