WinXP - Cryptographic Service

  wotbus@ 17:33 20 Dec 05
Locked

I have just unsuccessfully tried to install SP2 from disc onto a friends PC, and it failed because "Cryptographic Service is not running. Please ensure" etc etc. I was not aware this was something the user could or could not chose to have running! Would anyone know how make sure it is running?

  VoG II 17:36 20 Dec 05

Start, Run, type

services.msc

and click OK.

Double click on cryptographic services, click the Start button and change the Startup type to Automatic.

  PaulB2005 17:37 20 Dec 05
  wotbus@ 17:45 20 Dec 05

Wow thanks VoG™ and PaulB2005. Learn something everyday, much obliged.

  ade.h 17:49 20 Dec 05

Also worth reading the Services guide on The Elder Geek's website for future reference. click here

  wotbus@ 19:37 20 Dec 05

Thanks ade.h I was a bit premature with the resolved tick...Cryptographic Services "Automatic Startup" but marked "Stopped". When I clicked "Start" I get the following message "Cannot Start Error 127: The specified service could not be found"? The links provided have all the info I need except for this situation. I have looked on the MSKB but unable to find any reference to the problem, other than what VoG™ and PaulB2005 already suggested.

  wotbus@ 20:02 20 Dec 05

Hmmmm - if I right click Crypto Services then Properties I am wondering if the LogOn tab has something to do with it?

  wotbus@ 20:20 20 Dec 05

PaulB2005. On the link you provided, the last resort is to type several command lines ending with .dll in the run box. Do you type these in as single individual lines? Sorry if this seems a bit dumb but this is a grey area for me at the moment ;-)

  PaulB2005 20:24 20 Dec 05

Yes. Open the Run box, copy and paste the first line in and then hit enter. Then do the second until you reach the end.

There is a Batch File that you can download and run to automate the process at click here It might take a while to run.

  wotbus@ 20:30 20 Dec 05

OK and thanks for the guidance. I have just been searching the net for "error 127" and wish I had'nt started, crikey...looks like a reg problem. Thanks again.

  wotbus@ 10:37 21 Dec 05

Still no luck. I input the .dll lines as per the link click here
and after each one I received a box to say it was successful. After all the lines were inserted and confirmed I hit ESC to exit. Nothing happened so I closed the box on the X [top right]. I went again to Crypt Svc's and the status was not listed although the Startup Type was set to manual. I clicked Start [top left of box] but again the error message "error 127=specified svc could not be found". I changed the startup type to Automatic and tried to run the SP2 disc again which went almost to the end then the same box appeared "SVC Pack2 Setup Error. Setup could not verify the integrity of the file Update.inf. Make sure the Crypt Svc's is running on this computer". Groan :-(

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…