Windows XP Slow Shutdown

  Matt45 12:57 01 Apr 04

My PC seems to be taking a very long time to shup down now. I'm running Windows XP and when I shut down, everything goes fine until the screen where it says "Windows is shutting down...". Then my PC stays on this screen for around 90 seconds before actually turning off. I have three computers all networked and none of my other PC's take anywhere near this long. Does it sound like there is a driver conflict or something like that?

  GBL 13:10 01 Apr 04

mine is the same, so if yours is a problem so is mine.

  BurrWalnut 13:41 01 Apr 04

You could try this to speed up the closing of WinXP.

Run regedit and navigate to registry key
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet and click on the Control folder. Look for WaitToKillServiceTimeout, right click it and choose Modify. Change it to <2000, say, 1000.

  VoG II 15:17 01 Apr 04
  Djohn 15:36 01 Apr 04

As BurrWalnut says but reduce the number from 2000 to 200.

I have set mine this way and XP Pro. now closes almost instant [3-5 seconds]without any problems even if I don't bother to close any open applications and Broadband connection. j.

  tonyx1302 18:26 01 Apr 04

BurrWalnut/Djohn.Can you help re.closing XP? I get as far as Control folder but haven't got Wait to kill service timeout in that folder. Any ideas please

  hoverman 18:45 01 Apr 04

I haven't got WaitToKillServiceTimeout in that folder either. (XP Home)

  hoverman 18:55 01 Apr 04

Click on Control only - NOT the + sign to the left.

  tonyx1302 19:57 01 Apr 04

Hoverman. Sorry I must be stupid. I clicked on control and not =. Still cannot find it!

  Djohn 20:37 01 Apr 04

I think we are missing a little bit out somewhere? Try again this way, almost the same but seem to be overlooking one of the folders.

Start/run and "TYPE"


From here on be very careful not to make any changes unless you feel sure of what you are doing.

Look in the left-hand pane of the two panes on show. Click on all the "-" sign's to collapse your folder tree back as far as it will go.

Now all that should be showing is "My Computer" Icon with a + sign to the left of it.

Click on the + sign

Scroll down to the HKEY_LOCAL_MACHINE

Click on the + sign to expand that folder.

Scroll down to the SYSTEM folder and click on the + sign to expand.

Scroll down to the "Current control set" and click on the + sign to expand.

Scroll down to the "Control" folder and click on the folder itself.

Now look to the right-hand pane of the window and you will see.

"Wait to kill service" Icon.

Right click on that Icon, from the drop-down menu choose.


Left click on "Modify" and dialogue box will open with the figure 2000 inside it. Reduce this to 200 by left clicking to the right of the last zero then backspace to delete one of the zero's or highlight the whole number and change to 200.

Click on OK and back your way out of the registry saving as you go.

It's easier than it sounds, but take your time and go through it slowly and you will be OK. If at any time you feel unsure just back out without making any changes.

Remember to collapse your folder tree as I mentioned above then you can start right at the beginning and follow through.

Good luck j.

  tonyx1302 21:09 01 Apr 04

Djohn (How do I make the text bold like in your password?)

Many thanks Djohn. I followed your instructions to the letter and it worked. Your talents are wasted here. Thanks for your help and patience.

This thread is now locked and can not be replied to.

Battlefield 1 review: Destructive environments, phenomenal graphics and an emotional campaign make…

1995-2015: How technology has changed the world in 20 years

Microsoft HoloLens hands-on review

How to use System Preferences in macOS Sierra (and Mac OS X): Complete guide to personalising the…