Windows XP running slower and slower

  Dodger0 22:16 17 Feb 03
Locked

I have a Mesh XP 1800 running Windows XP Home, with 512Mb RAM and a 120Gb hard drive. Been working beautifully for about 6 months but then started to go slow. It got worse and worse. I tried restoring to the earliest point available (about 3 months before) but although it is not so bad, it hasn't solved the problem. There's still about 100Gb of memory available on the hard drive.

I get messages saying the virtual memory is low and Windows is adjusting it. (VM is set for Windows to manage it.) I installed a RAM checker and saw that the free RAM sometimes shrinks to around 80Mb. After running for an hour or so, the machine can get so slow that even a key stroke in an application takes seconds to respond.

Does anyone have any suggestions of how I can find out what has caused it, and what I can do to get back to a proper speed?

thanks.

  howard60 23:04 17 Feb 03

start - run - msconfig - top right tab [startup] and take the tick out of all the boxes except the firewall and virus checker. See if this improves it.

  PSF 23:08 17 Feb 03

Have you emptied your temporary internet files and temp folder. Also do a scandisc and defrag.

  vaughan007 09:00 18 Feb 03

USe a programme like Tracks Eraser to get rid of most of your temporary files. I am sorry I cant remember the exact name of this programme, but there is normally a one week free trial on it and it does a good job.

In your situation I strongly recommend doing a full scandisk.....if this is clear a defrag wont go a miss.

I know it is a pain but failing everything else try a full restore of windows using the CD that comes with your PC (a FULL restore, dont cut corners and go for the less time consuming options).

  Dodger0 22:13 20 Feb 03

Thanks for your suggestions. I've done a scandisk, done a defrag on the hard drive and cleared out all the temp files. I thought it had improved things, but after working on the machine for a couple of hours it went right back to running in treacle again. I ran Task Manager, which told me that available RAM was down to 7Mb (from 512Mb!) with the commit charge (virtual memory?) at 1.2Gb. This was after I had shut down all programs except Task Mgr. There were still dozens of processes working, with one called "svchost.exe" using 400Mb of RAM! If I pressed anything, the hard drive light went on continuously - presumably because there was no RAM to work with and everything was going to and from the hard drive.

Does anyone know what "svchost.exe" does and whether it is reasonable for it to gobble up so much RAM?

Thanks

  Djohn 22:35 20 Feb 03

click here This will explain. J.

  woodchip 22:41 20 Feb 03

You may have got a Virus

  vaughan007 09:02 21 Feb 03

It does sound like you may have a virus.

  the lone cloner 22:02 21 Feb 03

go to system props/advanced-preformance/advanced-virtual mem -change (double existing settings) this will sort it out.

  Gaz 25 01:02 22 Feb 03

click here - Great free virus tool!!!

  howard60 07:53 22 Feb 03

I wonder if perhaps the cooling in your pc is not as good as it should be. If you notice it ok when you first switch on cold and it then slowly slows up your problem could be a heat build up. A very simple thing to do would be take the cover off and see that all fans do rotate and continue to rotate. I have had fans that work ok to start and then stop after 10 mins or so. If with the case open and the inside cool you do not get the slowing up then adding fans would be the way to go.

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

The Pantone Colour of the Year 2017 is Green

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…