Windows says no virus enabled (I use Avast Free)

  wildhouse 17:54 16 Jun 14
Locked

Hi I don't know if this is a problem with my or Avast. The last few days Windows Action Centre keeps telling me my Virus Protection is turned off and won't let me turn it on. I use Avast free. In the meantime, every time I log on Avast keeps giving me a pop-up telling me I have a dodgy Add-on (Ad-aware) but it won't let me remove it without changing my homepage and search engine. I have uninstalled Avast and re-installed and got a day without either message (re Add-on or Windows saying no virus enabled). Now thinking I had better change my virus protection. Thinking AVG (want a free one!). Used this for several years in the past then it kept being at odds with something in Windows. Anyone any suggestions to either my above problems or a decent free virus protection? Thanks in advance.

  woodchip 18:52 16 Jun 14

Double click on Virus Icon on Desktop look for auto fix problems

  wildhouse 19:03 16 Jun 14

Hi I can't spot a virus icon apart from the one from Avast telling me everything is OK. I have been removed the browser clean-up option in Avast and now in the Solve PC issues icon my PC tells me I have no virus software installed. Going to re-boot and see if that makes a difference.

  wildhouse 19:30 16 Jun 14

Have re-booted and I'm not getting the virus disabled message. Equally, in the Action Centre there is nothing anywhere about virus protection, enabled or otherwise. Keeping my fingers crossed as the Avast icon is spinning around that it is working OK.

  Fruit Bat /\0/\ 20:17 16 Jun 14

Sometimes you need to reboot before a virus is removed to the virus chest.

Avast is the best of the free AVs

What antimalware do you have?

I back up Avast with Malwarebytes and Adwcleaner to get rid of PUPs and browser add ons.

  wildhouse 21:25 16 Jun 14

I use Malwarebytes, too. Haven't tried Adwcleaner but will look into that. Thanks.

  wildhouse 19:02 17 Jun 14

Well, I've logged on again today and once again the Action Centre is telling me I have no virus protection - I keep trying to enable it (I tell it I am happy with the Publisher) but it doesn't work. Now unsure if it is Avast that is the problem or my PC. The Avast icon was spinning before I ran Windows Defender but now it's not.

  mart7 19:15 17 Jun 14

Has this occurred after recent windows updates ?

i run AVG and on a few occasions after windows update i get the little problem flag on the task bar popping up saying my antivirus is turned off,when it clearly isnt,ive not solved it yet,goes away after a few days

This thread is now locked and can not be replied to.

Intel Coffee Lake 8th-gen Core processors release date rumours

1995-2015: How technology has changed the world in 20 years

Framestore’s haunting post-WWII title sequence for new BBC series SS-GB

How to install MacOS Sierra on an older Mac: Get Sierra running on Macs & MacBooks from before 2009