Windows Media Player won't initiate

  Nickelback1 20 May 11
Locked

Currently running Windows 7 Home Premium 64 bit & WMP wont start through any link or directly from the windows folder by clicking on the .exe file. Anyone know the fix or how it can be repaired ?

  rdave13 20 May 11

Have you checked the box is ticked in Turn Windows Features on or off.

Control panel - programs- programs and features and select Turn Windows Features on or off on the left side. Scroll down to media features and click on the + sign.

  Nickelback1 20 May 11

Yup, checked that all OK

  rdave13 20 May 11

Try this, untick the box for WMP, wait for a few seconds and close the opened windows. Reboot and go back and tick the box again. Close the windows and try WMP again. If that fails then try sfc /scannow; Option two.

  Nickelback1 21 May 11

Used this & fixed it - scripting error

http://support.microsoft.com/mats/windowsmediaplayer_diagnostic

  rdave13 21 May 11

Thanks for the feedback. Great that it worked. Unfortunately that link shows 'We're sorry, but the diagnostic solution you have requested is not available at this time.' for me. Found this - 'Do this to reregister the Jscript.dll and Vbscript.dll files.

Start - type in Search box - COMMAND find at top of list - RIGHT CLICK - RUN AS ADMIN

type in or copy and paste -> regsvr32 jscript.dll
Hit enter

type in or copy and paste -> regsvr32 vbscript.dll Hit Enter

Reboot and hopefully it will run now.' from link

Wonder if it's the same solution?

Advertisement

This thread is now locked and can not be replied to.

Should I upgrade to Windows 10? 8 reasons why you should upgrade to Windows 10... and 2 why you…

We are being sold the ability to spend money we don't have. And we love it

Wacom Cintiq 27QHD review

How to use Apple Music in the UK: Complete guide to Apple Music's features

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message