Windows Compatibility Issue

  Batch 18:47 30 Dec 06

I have an old program (an interactive French-English Dictionary) which was originally developed for Win3.1 and DOS5.0 (or above).

I have succesfully installed this program on my laptop, under WinXP-Pro by simply running setup from the CD.

However, I cannot get the same application to run successfully on my desktop PC (under WinXP-Home). The installation appears to go OK and all the files are copied across OK. When I attempt to run the app, I get a message "CREFWIN caused a General Protection Fault in module CREFWIN.EXE at 0002.0831".

I have tried various compatibility settings with no joy. Have also tried running the install from a CMD prompt. Still no joy.

However, I have found that if I start the app from a CMD prompt it works OK. This is a bit of a pain, particularly as the app consists of two .exe modules (one French-English and the other English-French) which do automatic look-ups in the other when you right click a word in the other language - the second module fails if it also hasn't be pre-loaded from the CMD prompt.

Now, I would accept that the hassle with the CMD prompt might be something one would have to live with due to backwards compatibility issues; BUT why does it work OK under XP-Pro, but not XP-Home???

Does anyone have any ideas or suggestions as to settings I might change to get it to work under XP-Home or is there some fundamental difference between XP-Pro and XP-Home that would account for the different behaviour?

  Batch 15:27 31 Dec 06

It seems that the problem is associated with trying to open the application in a maximised window. If I change the relevant value in the application's .INI file to not open maximised, it works OK (as long as I don't then close the app with the window maximised, as this causes the problem to occur next time round).

This still doesn't explain why it works OK on one PC and not the other. I did think it might be to do with the screen resolution / aspect ratio being different (between the two PCs), but I've established that this isn't the problem.

This thread is now locked and can not be replied to.

LG G6 review: Hands-on with LG’s bold, big-screen shot at perfection

1995-2015: How technology has changed the world in 20 years

How the painting-like animated sequences in A Monster Calls were created by Glassworks Barcelona

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…