Windows 7 LAN settings,

  Allan RISC OS user 12:35 06 Dec 09
Locked

The following instructions are for Windows XP, and worked well for me, but I have now upgraded to Windows 7 and I am unable to find the sections mentioned, so I am unable to run LanMan98 over my LAN, can anyone out there advise me how/where I can find them in the new OS.

........now go back to the original Local Area Connection Properties window. Click on the Advanced tag at the top of the window. This opens the Internet Connection Firewall configuration panel.
For maximum security you should have the firewall enabled, make sure the Protect my computer... option is ticked. Then click on the Settings button at the bottom of the window. This will open the firewall settings window.
A complicated list of Services should be listed, and if this is a new WindowsXP installation, they will probably all be unticked (off). Everything will be disabled and LanMan won't be able to connect to the PC. To rectify this we need to add a couple of new services to the WindowsXP firewall.
Click Add and a blank Service Settings window will open. This requires four parameters to be added. In the Description of service box, enter netbios-ns
In the Name or IP address of computer hosting this service box, enter the IP address of your RISC OS machine which will be running LanMan98.
In the External Port number for this service box, enter 137 and ensure the UDP button is ticked.
In the Internal Port number for this service box, enter 137
Click 'OK' to create this new service. You now need to repeat the process for the other service required for LanMan98 to function correctly.
Click 'Add' and a blank 'Service Settings' window will open again. In the Description of service box, enter netbios-ssn
In the Name or IP address of computer hosting this service box, enter the IP address of your RISC OS machine which will be runningLanMan98.
In the External Port number for this service box, enter 139 and ensure the TCP button is ticked.
In the Internal Port number for this service box, enter 139
Click 'OK' to create this new service. This should now have created the two services you require for LanMan98 to function correctly.

I can ping the Acorn RiscPC and it can ping back, the Network connection between my real Acorn RiscPc and my Virtual RiscPC on the Windows 7 PC are fine as before, but LanMan98 is note able to connect/access shared files on the Windows PC as the above have not been set. I know that the Windows PC will never be able to see The Real RiscPC. I think the share system is far more complicatedin 7 and XP which was straight forward and you could see when a file was shared by the hand icon, or have I missed something, I have only had 7 for 2 days.

  mgmcc 13:52 06 Dec 09

If the RISC OS PC cannot access Windows 7 with the Windows Firewall disabled, I cannot see how enabling particular ports is going to let you get connected when the Firewall is enabled.

Try this. Navigate in the Win 7 registry to:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\LSA

...see if there is an entry for LmCompatibilityLevel and, if there is and its value is "3", change it to "1".

The effect of this is to change the authentication level from "Sending NTLMv2 response only" to "Send LM and NTLM". This fix was sometimes necessary to overcome LAN authentication issues in Vista. I'm not sure if the same applies in "7".

  Allan RISC OS user 14:38 06 Dec 09

Thank you for reply, but perhaps I have not made it clear, I can use the LAN, and all functions are working except one feature namely LanMan98 which needs certain setting to be entered, and I have not found a way to do this in Windows 7. I encluded the instructions for XP in my thread because they DID work, but where do I find the places to put them in Windows 7. They are embedded in there so where!

  Allan RISC OS user 14:40 06 Dec 09

The last line should read "there some where"

  mgmcc 16:38 06 Dec 09

I know what you're saying - by entering those settings in XP's version of Windows Firewall you were able to access the "shared" folders/printers. However, if the Firewall is *disabled*, those settings must surely then become irrelevant.

Therefore, if Windows 7's Firewall is disabled and you still cannot access the shared folders, something else must be blocking access, such as "permissions" perhaps?

There are facilities for configuring Windows Firewall in Windows 7. Open the Firewall ("Control Panel > Windows Firewall") and click the Advanced Settings link at the left.

  Allan RISC OS user 13:17 08 Dec 09

Thank you for your help, I have found that which you mentioned.

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Hands-on with the Star Wars fighting drones you can fly yourself

15 macOS Sierra tips | How to use macOS Sierra: Secret tricks and best new features in Apple's new…