Windows 7 icons keep moving

  Seadog 00:26 04 Dec 09
Locked

Hi, I have a new pc with Windows 7 professional 64 bit which I am gradually getting used to after Xp but am having problems with the desktop icons changing position!

I am running a kvm switch (DVI and usb) to control two pc's (if this helps) and when I change between the two computers, the icons on the win 7 pc re-arrange themselves for some reason. Once re-arranged though, they stay that way - but it's not how I want them to be!

This is annoying but I have tried all the 'personalise' settings and also un-checked the 'allow themes to change icons' settings but am now stumped!

There must be a simple explanation for this, could it be related to the kvm switch running on dvi? Maybe because I am switching between pc's the graphics card(s) are resetting to some sort of default values for the displays? I previously was running two pc's on a vga kvm switch with no problems.

  User-312386 08:31 04 Dec 09

I am not at my pc at the moment but is it not right click on desktop>arrange icons and untick auto arrange or arrange by application

  chub_tor 09:11 04 Dec 09

click here works with Win7 32 bit, never tried it on 64 bit. It won't fix your icons but at least with one click you can get them back to where you want them each time.

  Seadog 09:23 04 Dec 09

madboy33--I've tried that, they still keep moving!

Chub_tor - thanks, I'll keep that in mind if I can't solve the problem.

The main problem is that the icons, which are in one and a half vertical columns so to speak on the left of my desktop, move and leave one icon space about half way down. Almost as if I had un-installed an icon/program - which I havent! The icons change places with each other as well, all apart from the recycle bin which stays put in the top left corner of the screen.
I might add that this appears to only have started since I changed the icon size from medium to small after adding more program and shortcut icons.

  rawprawn 09:37 04 Dec 09

Right click on your desktop> Sort By> untick everything

  birdface 11:02 04 Dec 09

Have you tried right clicking your desktop.View.
Make sure Auto Arrange Icons is unticked.

  Seadog 11:24 04 Dec 09

Thanks but yes, I've tried both but they still move, oh and the recycle bin has now moved as well!

The only thing I haven't tried is to disable the desktop theme slideshow or whatever it's called. (I have the 'allow themes to change icons' un- ticked)

I'll try that now and see how it goes.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

VFX Oscar nominees 2017: Discover how the visual effects were created

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…