Windows 2000 Roaming Profile Problems

  Gaz W 17:49 10 Feb 03

I posted a thread a while ago about a similar problem to this, which I thought I had resolved. I have roaming profiles on my Windows 2000 Server, and the clients are running Windows 2000 Professional and Windows XP Professional.

I will try and explain the problem as simply as possible.

The roaming profiles for each user are stored in this location: \\server\Profiles\%username%. When a user logs on, this folder, EXCEPT for the My Documents folder, gets copied to the C drive in C:\Documents and Settings\%username%. It doesn't copy "My Documents" because I excluded this folder from roaming with the profile using group policy.

So, the user has logged on and they have a copy of their profile (minus My Documents) on the C drive. The Folder Redirection points to the profile on the server (\\server\Profiles\%username%\My Documents or Desktop or whatever), and basically the user works directly on the server, which was the intention. There is a drive Z: mapped to \\server\Profiles\%username%\My Documents.

The problem comes when the user logs off. The local copy of the user's profile (C:\Documents and Settings\%username%) is copied back to the server (\\server\Profiles\%username%), COMPLETELY OVERWRITING ANYTHING THAT IS THERE. This means that the "My Documents" folder is DELETED!

The problem I had before was that you couldn't delete any documents because the My Documents folder was being copied back and forth, and the old folder was being copied over the new one on the network. That's why I stopped My Documents from roaming with the profile.

How can I stop this from happening? I don't really want a copy of the profile to be made on the local C drive in the first place, but if it really has to make a copy, I at least don't want it to be copied back, overwriting the profile on the server, which is newer!

The only solution to the problem I can come up with is to put My Documents and maybe Desktop, Start Menu, etc, into a separate folder that is not the same as the user's profile. This would prevent the files from being copied, but really I want to keep the user profiles all in one place.

What do I do?

  spikeychris 18:33 10 Feb 03

Hi Gaz

I take it the last workaround failed, have you tried this, Under "User Config", Admin Templates", "System", Logon/Logoff", "Exclude
Directories in roaming profile"

For others interested click here for previous thread.

Good luck


  spikeychris 19:23 10 Feb 03

Just had a thought on this, is it that you don't want to copy the Internet history and settings etc? you can do this with a registry hack

[HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Winlogon]


The value contains a list of folder names (as found in the root of your
Documents and Settings) separated by semicolons.


  recap 19:23 10 Feb 03

Sorry Gaz W can't help with this one this time. Looks like this one is for Andy?


  Gaz W 19:31 10 Feb 03

Thanks for linking to the previous thread.

I have already used the "Exclude directories in roaming profile" policy to stop "My Documents" from being copied from \\server\Profiles\%username%\My Documents to C:\Documents and Settings\%username%. Before that, the My Documents was being copied to C:\Documents and Settings\%username%, you would edit the documents on the server and then they would all be overwritten because they would be copied back to the server from drive C.

If by the last workaround you mean the one I mentioned about moving the My Documents, Desktop, Start Menu, etc, folder redirection to a directory not in the profile, I was hoping this could be a last resort - really I want to keep these folders in with the profiles, so they can all be in one place.

I just need it to stop copying the files to C drive, or at least stop copying them back to the server after copying them to C drive.

  spikeychris 19:46 10 Feb 03

Delete cached copies of roaming profiles

click here


  Gaz W 20:12 10 Feb 03

Delete cached copies of roaming profiles is actually already Enabled. I did this a while ago, when I was still experiencing the problem, because the computers were full of users' cached profiles.

I think all this does is delete the cached copy when you log off, but obviously it doesn't do this before it's copied it back to the server, unfortunately!

  spikeychris 20:41 10 Feb 03

Have you tried the regedit as this will prevent the local profile from expanding too quickly


  spikeychris 20:42 10 Feb 03

Your right about DCC.

  Gaz W 21:24 10 Feb 03

How do you mean the regedit? Will I have to do that on every machine? Do you mean this one?

[HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Winlogon]

Probably a silly question, but do I do this on the clients, the server or both?

  spikeychris 22:25 10 Feb 03

Not a silly question, do this on all clients. click here for a better explanation than that I gave.


This thread is now locked and can not be replied to.

Microsoft Surface Studio PC release date, pricing, design, features and spec: Microsoft showcases…

1995-2015: How technology has changed the world in 20 years

This amazing app turns your iPad Pro into a Cintiq

Apple Q4 2016 financial results | Apple earnings report: iPhone, iPad and Mac sales down, profits d6…