WIN32 Trojan or hardware problem

  Tatiana 16:01 23 Feb 07
Locked

While loading audio CD's into iTunes, my PC went crazy. The sound was broken-up and stuttering. I couldn't close iTunes or get a response from the 'start' buttons, so I had to do a reset.
The PC (Athlon 64 3500+) booted into XP very slowly. The slash screen was displayed for much longer than usual and the desktop took ages to gradualy appear. I was running AVAST and the Windows firewall but the PC is permanently connected to cable broadband via a router so I suspected a virus. I instigated an AVAST thorough scan, but it was running so slowly, two hours later it had only scanned a small percentage of the files. I cancelled AVAST and ran Adaware. This flagged up WIN32.TROJANDOWLOADER.AGENT and WIN32.TROJAN.AGENT, apparently in C:\system volume information\_restore.... AVAST also triggered at the same time. The files were cleaned and he PC re-started. Still running very slowly. I have since tried PCTools Spyware Doctor, Panda Antivirus 2007, Kaspersky, AVG Free and Trojan Hunter. Spyware Doctor reported a Keylogger and some minor threats which deleted, but the PC is still dead slow. At times, disconneced from the router, Task Manager shows the processor running at 90-100%, mostly attributed to 'System idle process', but at others, the system seems to run fairly normally, but it can't handle sounds without breaking up and stuttering. At other times, the machine will take minutes to respond to a mouse click or key press.
I've had clear thorough scans from Kaspersky, Avast and Adaware.
I'm not sure if it;s a virus or a hardware issue.

  anniesboy68 16:40 23 Feb 07

Try this site, they are very helpful

click here

  skidzy 17:31 23 Feb 07

Are these Antivirus apps all installed ?
If so,firstly get rid of them and keep just one,this will reduce conflicts that may result in a slow system.

Then run your AV in safemode.Tapping F8 on startup with get you into safemode.

If task Manager is reporting system idle at 90-100%,this is fine.

I would try and remove anything from add and remove programs that is not required and then run ccleaner click here and reboot.

If the problem still appears,you could try (somewhat debateable) disabling system restore and reboot,you will lose all restore points,then enable system restore.

  Tatiana 10:44 24 Feb 07

anniesboy68 - I am going through the processes required to send the 'Hijack This' file to Mal ware Removal, but it's taking a long time to complete the processes due to the slow PC.

skidzy - I have only installed the virus checkers one at a time, then removed them. I currently have AVG Free plus AVG Anti-spyware installed.

Total Processor usage is shown as nearly 100% in desktop 'idle' condition - most of which is 'system idle process'.

I have already disabled system restore as I was running out of options (and knowledge)

As I have started down the road of anniesboy68's suggestion, i will continue down this track for the time being, but thanks to both of you for the information

  Tatiana 15:56 24 Feb 07

skidzy

Ran AVG Free in safe mode - no threats reported.
Also downloaded and ran ccleaner.
Unfortunately still no improvement - very slow boot, stuttering sound and long response times to mouse movements and key presses.

  skidzy 16:30 24 Feb 07

Ok,try this

Start/run and type MSCONFIG and select startup,untick everything except your AV and firewall.If you have AVGAS still running in the trial that gives you real time protection,leave this also.
Now reboot.
You say the system is slow to boot,lets hope its one of your startup programs.

You should also consider a Disc clean and defrag at this time,also check the drive for any errors.

Start/My Computer/right click the C: drive/properties/tools.

If all this fails,maybe the drive is starting to fail,but i little to early to really consider this.

  Tatiana 18:32 26 Feb 07

Skidzy

Thanks for the efforts you have put into your responses. However, over the weekend, the situation deteriorated to the point where the machine would no longer boot into windows. Due to family pressure to get the machine running again, I eventually took the decision to replace the hard drive and start afresh.

Needless to say, all is now well, and I am running up to date versions of AVG virus and anti-spyware software and Zone Alarm.

Thanks again for your time and effort.

This thread is now locked and can not be replied to.

Sniper Elite 4 review: Headshotting Nazis has never felt so good

1995-2015: How technology has changed the world in 20 years

The Best Design, Illustration, Animation and VFX Awards of 2017

WWDC 2017 dates: How to get WWDC 2017 tickets, when is WWDC 2017 and more details announced