Win2k & Win2k dual boot

  y_not 05:26 29 Mar 03
Locked

I am wanting to dual boot my system to speed up video encoding etc. - the idea being that one O/S will only contain software necessary for the editing & encoding whilst the other O/S will contain Office etc (all the usual junk).

I thought that I had understood the reply to my earlier posting click here but, this is the current set up: -

Standard Win2k is set up on G drive (and works fine

I want to set up a second copy of Win2k on D drive (a separate drive - not a partition of G)

When I went to install Win2k the only location that it was offering to install to was G drive (I assume that would have overwritten the existing O/S so I canceled it)

Now on booting up I get the option to boot to Win2k or Win2k SETUP. If I choose the second option it offers to install onto G drive...which I don't want........do I?

I would have "walked away" when the problem started but for this boot option issue!

Can anyone help please?

  temp003 06:25 29 Mar 03

Sigh!

I've just posted a rather long-winded message on your other thread, on the assumption that you have succeeded or will succeed in installing the 2nd copy. So ignore that post.

You're right, you don't want to install again to the G drive.

I don't know why your D drive is not available for installation. Is it not even shown on the list of partitions, or is it shown, but when you select it, w2k Setup tells you you can't do it, or some error message?

Since your copy of w2k is on a G drive, it suggests that you may have a rather complicated partition system, but I don't know.

Your idea of having 2 copies of w2k is actually a good idea. But if there's a problem installing it, then bad luck.

If that problem cannot be resolved, and you want to remove the boot option for W2k Setup, here's what you do.

These instructions are on the assumption that there's only one active partition (the partition the computer boots from), which is your C drive. If you have a different configuration, please post back.

Start computer and select the proper w2k copy from the selection screen.

First make sure that your default OS is w2k proper, and not the setup (this should be shown on the boot selection screen when you boot up the computer).

But check it anyway. When you're in w2k, right click My Computer, select Properties, Startup and Recovery.

Under the section default operating system, see if it shows the default OS as "Microsoft Windows 2000 Professional" /fastdetect. If so, leave it alone.

If not, click the drop down list and select it. Click OK to exit.

Now go to your C drive. See if you can find the file boot.ini

If not, click Tools, Folder Options, view tab. (1) Tick "Show all hidden files and folders". (2) Untick "Hide file extensions for all known file types". (3) Untick "Hide protected operating system files". click OK.

Double click the file C:\boot.ini to open it in Notepad.

First check that the line in the file that begins with default= reads:

default=multi(0)disk(0)rdisk....\WINNT

If it's like that, it means you have successfully changed the default OS back to w2k proper, and not the Setup.

Then look under the section [operating systems]. One of the lines should be (ought to be the second line from your description):

C:\$WINNT$.~BT\BOOTSECT.DAT="Microsoft Windows 2000 Setup"

Delete that line.

This is the only change you need to make.

Save the changes and exit Notepad. Restart the computer and you should boot straight into w2k, without the OS selction screen.

When back in w2k, go back to the C drive and find the folder $WINNT$.~BT

Delete the entire folder. This is the temporary installation folder from which w2k Setup boots, and which, had the installation been successful, would have been removed by Setup. You can delete the folder now, since you're not proceeding with the installation.

This will clean your computer of the remnants of the aborted installation.

But as I said, your computer configuration may be different (for example, if your active partition is your G drive, then the instructions need to be corrected).

There may also be a way of overcoming your installation problem.

  y_not 06:51 29 Mar 03

Thanks for the reply and Yes I did read all of both replies (Don't you worry about the risk of RSI from all that typing - only joking).

For my sins yes I do run a "less than straight forward" system. To explain: -
Disk 0: G:/ = 20Gb & K:/ = 37Gb partition
Disk 1: D:/ = 5Gb & C:/ = 15Gb
Disk 2: H:/ = 10Gb
Disk 3: I = 10Gb
Disk 4: J:/ = 20Gb & L:/ = 17Gb & M:/ = 20Gb

All are formatted NTFS
The partitions are due to the main-board getting upset at drives of more than 20Gb (but for some strange reason it does accept the 37Gb on G Drive!)

G:/ shows as "System", D:/, H:/ & I:/ all show as "Active" and the rest show as "Healthy".

All are available and working okay.

When I try to load the O/S I selected the option to decide where to load the second copy (which was in an "advanced" setting) but the option comes up to Repair an existing system, Install a new system, F3 to quit. Below it shows the (I assume) available locations. In that box the only drive showing is G:/ and I really don't want to overwrite the existing O/S.

Any others suggestions will be welcomed.

This must be my longest response yet - you don't think that typing is contagious do you?

  temp003 09:12 29 Mar 03

The descriptions of "system", "active" and "healthy" sound like those shown ini Disk Management. Is that right?

Do you also have some third party software to allow you to call the system partition G and not C (just out of curiosity)?

The partitions marked as active all happen to be the first partitions (I assume) in the other disks. To be able to be marked as active, they must be primary partitions.

But my understanding is that in w2k, a primary partition does not have to be marked active, but I'm not sure. I mention this only because either some third party software has done this, or whatever method you used to create the partitions, the primary partitions were also somehow marked as active during the process. The presence of third party software may complicate things a bit.

In any event, I don't know whether the presence of the active partitions is the cause of the installation problem.

So, I'm just thinking aloud (again rather long-windedly, even when thinking).

From your description, it sounds as though you started the Windows CD from within Windows 2000 itself. It may be that the fact that you were in Windows itself limited your options of installable partitions (but I'm not aware of any such restrictions myself).

I suggest you simply remove the w2k Setup boot option first, and then either forget about the 2nd copy of w2k, or if you want to try again, boot from the w2k installation CD this time to see if it makes any difference.

But since this involves you in editing the boot.ini file, and because of your slightly unusual drive letter system, I suggest you create a boot floppy first before you edit boot.ini, in case my instructions for removing w2k setup are wrong.

While in Windows 2000, insert a floppy. Right click drive A (I hope it's letter A this time!!!) and select Format. Do not tick any of the special options. Just click Start. You must take this step (1) within Windows 2000, and (2) even if the floppy is completely new.

After formatting, copy the files ntldr, ntdetect.com and boot.ini. Since your G drive is described as the "system" partition, the boot files will be under G. If you can't see them, take the steps described in my last post.

Test the floppy by restarting the computer with it. So leave the floppy inside the drive and restart. Make sure that in BIOS setup, the floppy drive comes before the hard disks in the boot sequence. Otherwise the computer will still be booting from the hard disk, and you will not be testing the floppy.

You should still see the boot options. Select w2k. If the computer boots into w2k, your floppy works. You can keep this floppy as a back up for the time being, to boot you into your otherwise healthy w2k, if necessary.

You can now remove w2k Setup. Follow the steps above. Only that for C, read G. Otherwise there should be no difference.

After you have removed w2k setup, if you still want to try installing a second copy. Boot from the CD to see if Setup allows you to select drive D.

If it does, try it. The only warning is I don't know whether it will change your active partition (by that I mean not just whether a partition is marked active, but the very partition from which the computer boots from). But this should not be a problem. If anything goes awry, use the boot floppy to go back to w2k.

The alternative, if Setup shows the D drive but does not seem to allow you to install to it, is to delete the D partition first, and re-create it, then select it as the partition to install the new copy of w2k. You'll be prompted to format it. Do so. W2k will then sort out the question of which partition to boot from.

  y_not 06:31 02 Apr 03

for now, seems to be to remove the setup for the second copy - thanks very much for the info on how to do that.

I don't feel that I understand the answers well enough on how to set up the dual boot so I'll spend some time reading first - too much at stake to start losing things cause I do it wrong.

Many thanks for the advice......will probably be back after I've read up and tried again!

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

These are the Best Christmas Ads and Studio Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…