Win2k - printers not working

  Wrinkles 01:04 10 May 03

I have AMD 750, 256Mb RAM. Two printers, an old HP laserjet IIIp and an EPSON colour 440 connected via a manual switch box.

I have just spent a couple of hours upgrading from win 98 to windows 2000. All went well and apart from having to install a few things not too traumatic, or so I thought.
Then I went to print something and neither printer worked. I updated the drivers uninstalled both re-installed both, connected each direct by passing the switch, etc etc all to no avail. I would appreciate any ideas you might have as to the cause of the problem

  Wrinkles 00:41 11 May 03


  John-259217 02:24 11 May 03

If your happy that your printers are working correctly (self-tests) and that your using a known good cable, I would check the local print spooler setting in Control Panel/Services. This will need to be started unless the printer drivers have been set to bypass it. It may also be worth checking the parallel port is appearing correctly in the device manager.

Unfortunately I don`t have a Win2000 system to hand at the moment or I would have replied to this last night - I`d hoped someone else who did would have been able to offer more detailed advice :-(

  mrdsgs 09:12 11 May 03

try disconnecting the cables, deleting the hardware in device manager and deleting all relevant software and drivers.

then switch off computer.

reconnect everything and switch a printer on (only do this with one prinyter at a time)

power on the pc and you SHOULD get the "found new hardware" screen. Should be easy from there.

if this fails, if you are using usb, try a parallel printer cable or another usb device.

sounds more likely to be a usb driver issue if other devices are not picked up as well.

W2000 usb drivers on motherboard driver cd/disk?

good luck

  recap 13:45 11 May 03

Check the port number for the printer is correct.

  Wrinkles 19:42 11 May 03

Thanks for the replies, tried them all and so far no result.
Printers both work on other PC's as do all cables,
Tried both connected direct to PC(Neither are USB)
Deleted and re-installed ports and all software.
When installing under Win2000 system searches for printer in each case can not find it.
Conclusion port setting are at fault or LPT1 is not working.
How do I test this.
Could it be due to port settings in BIOS, settings (2) are Auto & normal.
A further thought could it be due to permissions in win 2000.
As I have only just installed Win2000 I amd not fully familiar with all the bits and tweaks.
any further help would be appreciated.
Kids need to print their home work so I'm getting grief

  mrdsgs 21:04 11 May 03

control panel/system/hardware/device manager/ports(LPT and COM).

double click on LPT1
various tabs then

1. general: should say "this device is working properly"
2. port settings: tick in enable legacy plug and play. Never use an interrupt

3. Resources: use automatic settings.

this is how mine look and my lpt printers go through a variety of switch boxes.

ps: You have got the printers switched on when you try to get windows to recognize them ?

good luck

  Wrinkles 22:49 11 May 03

HI Mrdsgs
All my settings match yours.
I have since gone through all the permissions I could find and given all access to printer.
I have uninstalled and re-installed as network printer.
It appears there is no connection from port. I fitted a brand new bi-directional cable and system searched for but could not find the Epson which should be PnP.

so What do I do now??

  John-259217 23:05 11 May 03

Are you logged on as an administrator or did you create a user account with lower priviledges?

It may not be possible to make a major system alteration in restricted user accounts.

I should say that Win2000 normally "picks up" settings from a previous O/S during setup -any problems are usually then down to incompatable drivers.

As your BIOS only lists two ways of configuring the parallel port it may be worth trying them both just in case. If further options are offered use ECP (extended capabilities port) this will ensure two way communication between the PC and printer.

Just a thought as you mention other computers have you got a network setup? If so makesure you are not setting up for network printing instead of local.

A little voice is telling me I`m missing something very obvious here but as I said I don`t have a Win2000 system handy to check every detail.

  mrdsgs 08:09 12 May 03

Make sure you install printers as Local rather than network printers and make sure you are logged on as administrator or at least that your user name has administrator privileges.

  Wrinkles 19:17 12 May 03

Again thanks for the input.
I am logged in as administrator, and yes although on a network I isolated it and installed as local printer.
And the little voice is nagging me also, these things are usually something simple and obvious. So far I can not see it.
I am currently awaiting a reply from a colleague, who is currently in Spain, who is a wiz with Win 2000.
In the meantime anything further will be appreciated.

This thread is now locked and can not be replied to.

Apple Event live stream | Apple October Event live blog: Watch Apple unveil new MacBook Pro, new…

1995-2015: How technology has changed the world in 20 years

Lida designs a cross-stitch email sent to thousands of Ikea Family members

Apple Watch 2 review | Apple Watch Series 2 review: Faster performance, a brighter screen, water-ret…