Win2k and Network

  TomG 17:39 21 Aug 04
Locked

I have 3 computers (2 win XP desktops and 1 win2k laptop) connected to broadband through a router.

If i startup the laptop it cannon connect to the internet but if i boot up one of the desktops first then the win2k laptop connects first time.

Any suggestions as to how to cure this?

  mgmcc 20:02 21 Aug 04

Are all three PCs definitely getting IP addresses automatically from the router's DHCP server?

With a router, no individual PC should be dependent on another being booted for its internet connection.

  TomG 20:31 21 Aug 04

As far as I know yes - each was setup individually.

Before i had broadband i had a wireless network with one pc connecting to the internet via a dial up modem. I did find with this setup that if the win2k laptop was booted before one of the xp machines it coudn't be seen on the network nor connect to the internet - i had to shutdown and restart.

  mgmcc 08:06 22 Aug 04

Before you had broadband and a router, you must have been using "Internet Connection Sharing", if more than one PC could access the internet with a single dialup connection.

With a router, you do not use "ICS" on the internet connection of an individual PC. Is it possible that you still have "ICS" enabled on a redundant dialup networking configuration and this is causing problems in that the Win2K laptop is somehow trying to get an IP address from an "ICS" host PC instead of the router?

  TomG 10:09 22 Aug 04

Yes you may be right - any idea how i turn it off on win2k?

  mgmcc 12:43 22 Aug 04

If the Win2k laptop was the 'client' with Internet Connection Sharing, it would have been one of the XP PCs which had its internet connection set as "shared".

In the XP PCs, have a look in the Network Connections folder. Right click the entry for the old Dialup connection and select Properties. In the Advanced tab, make sure there is no tick in the box "Allow other network users to connect through this computer's Internet connection".

I cannot actually tell you how ICS would be enabled or disabled in Windows 2000, as I don't currently have it installed in a PC.

  TomG 13:36 22 Aug 04

Ok thanks - that shuld sort it

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

New Corel ParticleShop plugin now available: 11 new brushes & 6 new brush packs

Apple AirPods review: Apple's beautiful new Bluetooth headphones bring true intelligence to…