Win XP/98SE - a pigglesome mess!

  Bodi 09:31 26 Aug 03
Locked

I have installed Win XP on my main partitioned hard drive (120GB divided into 3)and had Windows 98SE on the second drive and a SCSI removable drive. (From a previous installation)

The old 98SE installation wouldn't upgrade to new motherboard drivers and just hung. I formatted both drives with 98SE on them and tried to install 98SE on the second drive (80GB divided into 2) I changed the boot sequence in the BIOS to the previous "D" drive and installed 98SE. For some unknown reason, it installed on the same hard drive partition as XP and came up with a Windows protection error (not surprising!).

I've tried deleting Win98SE from the drive (Windows-000 folder)but XP insists it's still there and gives the choice of both operating systems. I have also tried reverting to a previous trouble-free restore point. No joy!

How can I get rid of 98SE from this hard drive partition? I only tried to install 98SE because my scanner won't work with XP (scanner installation insists that XP is NTFS format, when in fact it is FAT 32)

Help! Please.

Bodi

  Gaz 25 09:40 26 Aug 03

fdisk?

  Gaz 25 09:40 26 Aug 03

partition magic

  Bodi 09:50 26 Aug 03

I only have PM version 6 - which won't work with XP and I don't want to have reinstall XP again (it does work - apart from giving me the choice of the two operating systems).

I have made two boot disks of PM V.6 on another computer and followed Flecc's instructions from here:

click here

but chickened out when everytime I used my mouse I got deep constant beeps. (I am a coward!)

Bodi

  SheffieldSpy 09:51 26 Aug 03

XP will still think its there until you edit the boot file. If you go to "System" in Windows XP's Control panel and click the "advanced" tab. Then the "Settings" button under the Startup and recovery section. Click the Edit button under the system startup section. Now remove each line under the "[Operating systems]", except the one that says "multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect". If you haver Windows XP Professional edition it will say so, rather than Home Edition as I have.

  temp003 09:58 26 Aug 03

I assume you can still boot into XP, and your XP is otherwise fine (i.e. nothing has been overwritten by the 98 installation, such as the C:\Program Files folder)?

In XP, right click My Computer, select Properties, Advanced, Startup and Recovery, Settings. click the Edit button.

The boot.ini file will open in Notepad.

Assuming your main hard disk (with XP on it) is an IDE hard disk, set as the master, edit the file to read as follows:

[boot loader]

timeout=30

default=multi(0)disk(0)rdisk(0)partition(1\WINDOWS

[operating systems]

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home" /fastdetect

If your XP is the Professional version, change Home to Professional.

After editing, click File, Save. Then exit Notepad. click OK in Startup and Recovery Settings.

Restart computer. You should boot straight into XP without the choice of OS's.

Once in XP again, delete any other 98 system files and folders which you have not deleted (not clear from your post whether your 98 installation was complete or not).

  hugh-265156 09:59 26 Aug 03

use a boot disc with fdisk on it and type:fdisk /mbr

this will restore the master boot record.

  Bodi 10:00 26 Aug 03

Thanks! Will try that and let you know whether it worked.

Bodi

  xania 10:02 26 Aug 03

I can't comment on how to resolve XP short of starting afresh. I don't trust automatic backups and always mirror my current OS to a spare area on my HD before doing anything fundamental - any even that won't work with OE address book.

One probelm with the 98SE install disc (ant this may apply to all others as well) is that, if it finds another copy of Windows ANYWHERE on your system, it will default to load onto that. I suspect that this is what has happened - you need to make sure you change that option to the Partition you want to use.

Don't know what's gone wrong with your mouse on PM6 - I have used those floppy disks on many occasions, but it sounds is if you have a driver problem. Suggest you create new floppies on your current PC and see if that is any better.

  temp003 10:02 26 Aug 03

Sorry, SheffieldSpy has just covered it, but in my post there's a typo.

The default line should read:

default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

if it's not already like that.

  Bodi 10:05 26 Aug 03

will let you know how I get on.

Can anyone tell me why 98SE installed where it did? Just to avoid it happening again.

Bodi

This thread is now locked and can not be replied to.

iPhone 7 review: a range of small updates add up to an excellent phone

1995-2015: How technology has changed the world in 20 years

How New York’s Stylin’ Seniors became a golden social media campaign

23 Apple Watch tips & secret features: Master your Apple Watch, Apple Watch Series 1 or Apple…