win 7 cannot find drivers for Canon MF4120 printer

  dobbin 16:19 17 Jul 10
Locked

I have just tried to install my printer onto a new desktop running win 7 professional.

Although windows has found the printer it says it cannot find the drivers. I have downloaded them twice from the Canon web site. How can I force it to find them. As it is a usb connection I cannot find anyway to browse manually for the drivers. Does anyone have a suggestion as I really need to start printing.

  Sparkly 16:28 17 Jul 10

Hi dobbin i had a similar problem with a Pixma MP750 in the end i uninstalled everything to do with the cannon and rebooted then connected it again via usb and it found new hardware and installed a driver for me works fine, hope this will help. Windows 7 64bit

  onthelimit 16:31 17 Jul 10

Canons normally come with an installation CD - do you have one?

  onthelimit 16:32 17 Jul 10

How old and what model printer?

  onthelimit 16:32 17 Jul 10

Ignore last post - missed the model in your title.

  dobbin 16:34 17 Jul 10

yes I have tried the installation disc but this was failed. I think it was for win xp.

  northumbria61 16:36 17 Jul 10

Does this help - click here

  northumbria61 16:38 17 Jul 10
  dobbin 16:39 17 Jul 10

Thanks Northumbria but I have already been there and downloaded the drivers but for some reason win 7 cannot find them

  Forum Editor 16:42 17 Jul 10

that you said Windows finds the printer, but says it can't find the driver.

The driver you should be using is: MF4100_MFDrivers_Win_x32_EN_7.exe

Is that the one you downloaded?

  dobbin 16:44 17 Jul 10

I'm pretty sure that that was the one I used although I did not write it down. I will try once more.

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…