why wont my newly built computer turn on?????

i've been building computers for a while and for the first time ever i have built one that wont power up. i have checked all the individual components except the motherboard (because i'm too lazy to put a load of MY stuff on someone elses motherboard just to see if it works) by putting it all piece by piece in my own computer. so i know the ram, graphics card, hard drive and processor all work fine. my question is basicall this: i have tried two seperate power supplies with it, one of which is new, the other has worked but i havent had it going in a while. when i plugged the new one in, it made a strange clicking noise each time the power was switched on at the mains. hmmmmmm. so then i tried the other one and still nothing. i have been over all the jumpers and case connectors several times and i know they are right. can i kill a motherboard with a dodgy power supply or might it have been dead already? (maybe that was my actual question) if my motherboard is dead and my power supply is dodgy (the funny noises) should i send them both back and get replacements? i dont want to try the new power supply on another board in case it messes it up so how would i tell?
i think thats all my questions at once, so any help would be appreciated.

  hugh-265156 01:04 18 Feb 04

whats the rating of psu,model no of mobo and connected hardware please? may help a bit.

disconnect all fans(except cpu)and extra drives,pci cards etc.leave just a floppy,cd drive,graphics card and hdd see if it turns on maybe.

the psu's are both rated at 300w, the motherboard is a pcchips m848a, there is a hard drive (maxtor diamond plus 9, ata 133, my favourite hd) a cd rw (generic) and an msi radeon pro 7000 graphics card. the cpu is an xp 2700, there is a gig of 333 ram installed as well. oh and an old floppy drive too. i tried the disconnecting thing (it was only the case fan that i disconnected in the end) but still no joy. thanks for the help

  Indigo 1 01:14 18 Feb 04

Check the PSU with the paper clip trick

1. disconnect from mains

2 disconnect ATX connector from m/b

3. get a U shaped paper clip, plastic coated is best

4. stick one end of paper clip into ATX plug green-wire terminal ... stick other end into any black-wire termial on same plug

5. Turn on mains, you will notice if the PSU is working or not cos the internal fans will spin, using this method you can also check the output from the different pins to see if they are working with a voltmeter.

6. don't leave it turned on for more than a few seconds at a time or you will burn it out without it's correct load.

hi. whilst this sounds emmensely dangerous, i will try this but not till the morning. thanks a lot for this trick, i'm sure i will use it again in the future!!!!! if i die though i'm holding you responsible ;)

  hugh-265156 01:28 18 Feb 04


click here

as you have tried two psu`s though the board may be faulty.

check its not shorting against the tray.

  Indigo 1 01:32 18 Feb 04

It's not dangerous if you are careful, the max voltage there is 12v (or it should be) as long as you don't take the cover off the PSU you'll be fine :) trust mee ima ductor :-) :-p

This thread is now locked and can not be replied to.

Nintendo Switch (Nintendo NX) release date, price, specs and preview trailer: Codename NX console…

1995-2015: How technology has changed the world in 20 years

8 things designers (and brands) need to know about the modern woman

How to speed up a slow Mac: 19 great tips to make an iMac, MacBook or Mac mini run faster | Speed…