Why do images not look crisp on my new laptop?

I am on my brandnew laptop. The resolution is set to 1440x900 which appears to be the maximum setting and colour is set to the highest setting which is 32. The graphics card is an Ati Mobility Radeon X300, the screen is 17". The picture quality is not sharp. Small images such as thumbnails in Ebay are pixellated and some fonts are jagged around the edges (not "standard fonts but ones like in the PCADVISOR banner at the top of the page).Any idea how to remedy this- the driver looks to be a recent one (dated August 2005). Many thanks!

  johnnyrocker 14:34 19 Oct 05

have a look in the appearance settings in desktop properties.


  Granger 14:34 19 Oct 05

Was 1440x900 the screen resolution set when you got the laptop? Most have a "native" resolution which will look sharper than other resolutions.

Yes I think it was the resolution set when I got it, I didn't change it as the others were "lower" should I try other ones? Also under "monitor" it just has five "default monitors" using a 2001 driver, is this right- I have never had a laptop before so am n ot certain if the monitor counts as a monitor!

The other resolutions are truly awful! also in settings it says that i have "multiple monitors" using the radeon card.

  sharkfin 14:42 19 Oct 05


TFTs have one native resolution, all others will result in a blurry look. Try the other resolutions till you find it. It'll probably be 1280x768 or 1280x1028

  sharkfin 14:44 19 Oct 05

Also check if you have the driver installed for your graphics card.

Thanks- the driver looks up to date for the graphics card but what about the monitor driver is that relevant on a laptop. If anybody has the optimum settings its a DELL Inspiron 9300

  retep888 16:19 19 Oct 05

Is your laptop a wide screen one?

Are you using IE as your browser?

  Hamish 16:19 19 Oct 05

1440x900 the screen resolution appears to be right. Look at this review click here.

Also for other reviews look into Google

  w1z8rd 16:19 19 Oct 05

i have the exact same set up as you, a nd the only change i made was to set the font's to "clear type", if you havn't tried this it's in the display properties/appearence/effects"use the following effects to smooth the edges of fonts"

hope that helps as i don't have any problems with mine

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…