Why is Broadband on new PC so slow?

  pcbobby 15:47 10 Dec 06
Locked

My new PC is, AMD Sempron 3000+ 1.8Ghz. 512MB Ram.
OS XP Home sp2.

I use Tiscali 512 Kbps BB (local exchange limits higher BB).

I have found that the broadband speed is faster on my old PC. Compaq. P III 650Mhz.
OS XP Home.
I can mostly achieve 300 – 480Kbps, and occasionally 577kbps.
But the new PC struggles to reach 200Kbps!!!

I am aware that at peak times, Internet traffic can slow things down, but at 6AM, surely the speed should be better that those indicated above?

Is it possible to tweak the new PC for a better performance?

PS. I have tried Optimisers to no avail.

  Diodorus Siculus 16:25 10 Dec 06

What sort of modem? Could be that it needs an updated driver.

  pcbobby 16:28 10 Dec 06

The modem is, SpeedTouch USB ADSL 330.

  Diodorus Siculus 16:35 10 Dec 06

click here for drivers; if you don't have newer drivers, try these.

Is it connected via a hub or direct into the motherboard? IF possible, try the latter and see if there is an improvement.

  pcbobby 16:39 10 Dec 06

The USB is connected to the motherboard.
Thank you. I shall try the drivers and report back.

  spuds 16:44 10 Dec 06

I use the SpeedTouch 330 on the Tiscali 2Mb package, with the original drivers (never updated).All seems to work well with this set-up, and a five year old computer.

Perhaps using a new computer, with a different motherboard as slowed things down. There are some known problems with certain motherboards and the SpeedTouch 330. Check for new version drivers!.

  Diemmess 16:47 10 Dec 06

If all non internet use is faster, then it must be Internet hard or software that has the brakes on.

Apart from presumably the same Tiscali contract what else differs between the two computers.
Do you use the same modem for either?
The defensive stuff AV and firewall, are they the same?

Finally, because I like the little freebie program click here
Have you run this on both computers. (The advantage to me is that the program tells what the speed is, not what it is supposed to be!

  pcbobby 17:16 10 Dec 06

Sorry for the delay folks.
I was using the old(faster)PC and had to switch to the new PC.

I installed the driver updates. First log on, was 56 Kbps!

Second try was 206 Kbps. I will have another go after I send this.

The old PC is more consisitant: 212 - 478kbps.

Perhaps it is the Motherboard (Winfast 6100K8MB)on this new PC?

  pcbobby 17:23 10 Dec 06

Well, it gets better!
Speed now reads 476Kbps, best so far on this machine.

I am happy with that result.

Thank you to all for your help and input.

  howard64 19:38 10 Dec 06

useful for the speed test prog - thanks

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…