Where have the tabs gone in my Firefox?

  polymath 22 May 12
Locked
Answered

They disappeared recently, about the time I updated to Firefox 12.0 (I haven't been changing any settings lately). A tab used to appear for each web page I visited, that stayed visible until I closed it; now there's only a tab for the page I'm on.

I tried a little cross at the top left labelled 'open new tab', but I couldn't see anything happening. A little down arrow next to it, called 'list all tabs', just tells me what web page I can see in front of me (however many I've visited in the session). Tools - options - tabs has the option 'Open new window in a new tab instead', but it has no effect that I can see.

Is it some setting I could do/a feature of FF 12/me being dim/a combination of these? I can still use History to go back to recent pages, but it means quitting the current page. A task I want to do needs 2 web locations open at once.

Under History I can see 'Recently closed tabs' and 'Recently closed windows' options, but they're greyed out.

Vista SP2, Adobe Flash Player & Foxit Reader were also updated recently. I use AVG Anti-Virus Free Edition 2011 (updating automatically) & Windows firewall.

  lotvic 22 May 12

Not sure, the little + should open a new tab.

Have you tried rightclicking on a link and choosing 'Open Link in New Tab'

  lotvic 22 May 12

edit, as Not sure, the little + should open a new tab sounds unclear re meaning.

Should be: Not sure why the little + is not opening a new tab, it's supposed to.

  rdave13 22 May 12

Try starting FireFox in safe mode. Press the shift key when clicking on the icon. If tabs work ok then it could be an incompatible addon or plug-in.

  polymath 22 May 12

Just looked again at the 'Open a new tab' option (via the little +). It takes me to a page headed 'New Browser Tab', with a search box below, and a list of 'recently visited' (at least some of which aren't). I suppose it did constitute opening a new tab, but I had to use History to get back to this forum (which then became the only tag again).

  Woolwell 22 May 12

Open a new tab as you have and you get the recently visited etc. Do not go back but in that tab click on the home button and you will probably have a more recognisable page.

  polymath 22 May 12

Thanks rdave (I didn't see your post at the time). I tried opening FF in safe mode; no tabs there either (but thanks for reminding me to try Safe Mode more often for problems!)

I did that, Woolwell, and it worked. Thanks! At least, it works if I go to 'Open a new tab' each time I open a new page. I can do what I wanted to now, but has Firefox 12 done away with automatic tabbing? (There are times it could come in handy, if it's still an option).

  Woolwell 22 May 12

Not sure what you mean by "automatic tabbing". Do you mean open a new tab when you click on a link?

  polymath 23 May 12

Yes.

  Woolwell 23 May 12
Answer

Are you clicking and holding down the centre button on the mouse?

  rdave13 23 May 12

Just a thought, you don't have the ask toolbar in your programs and features list? This can cause problems sometimes or even another toolbar, even though you tries safe mode.

Advertisement

This thread is now locked and can not be replied to.

OnePlus 2 UK release date, price, specification rumours: When is the OnePlus 2 coming out? July…

We are being sold the ability to spend money we don't have. And we love it

HTC's head designer on what's exciting in designing for mobile right now

Apple Music preview: Why Spotify should be scared of Apple's impressive new music-streaming service

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message