Weird Problems with my new GFX card

  lothlann 12:09 03 Jan 07
Locked

Hi, i recently got a Nvidia Geforce 7800 GS and iyt seems to work ok except for a few weird problems.

Firstly from the CD my computer cant find drivers for SM Bus Controller or Other PCI Bridge Device. Im not sure what either of these do but at the moment they arent working and that could be causing the problems i am having.

On the loading screen for any game, particully Medieval Total War 2, i get white lines randomly appear across the screen but it then goes when the loading has finished. I also seem to be getting random crashes with this game but im not sure if its to do with the GFX card. I had to restart once and the computer wouldnt turn on for about 10 mins. It was stuck on memory testing.

The main problem is in games like World of Warcraft and Warhammer Mark of Chaos the font gets lines through it and goes blocky and impossible to read. Is this due to the missing driver my computer says i have.

------------------
System Information
------------------
Operating System: Windows XP Home Edition (5.1, Build 2600) Service Pack 2 (2600.xpsp_sp2_gdr.050301-1519)
Language: English (Regional Setting: English)
System Manufacturer: NVIDIA
System Model: AWRDACPI
Processor: AMD Athlon(tm) XP 3000+, MMX, 3DNow, ~2.2GHz
Memory: 1024MB RAM
DirectX Version: DirectX 9.0c (4.09.0000.0904)

------------

---------------
Display Devices
---------------
Card name: NVIDIA GeForce 7600 GS
Manufacturer: NVIDIA
Chip type: GeForce 7600 GS
DAC type: Integrated RAMDAC
Display Memory: 512.0 MB

  keef66 12:25 03 Jan 07

You could try installing the latest drivers from the Nvidia website.

Is the card a 7800GS which you posted, or a 7600Gs as your system is reporting?

  skeletal 12:28 03 Jan 07

I suggest you go to the nVidia site click here
and get the latest drivers; put the package where you can find it. Also have a look round nVidia’s site and read how to remove the old drivers; you must get rid of them first. Reboot the computer and it will go into VGA mode and will “find new hardware”, but won’t find its drivers. Ignore this and run the package you downloaded. This should put everything where it should be and hopefully get rid of the messages you have seen.

You will need to reset you screen resolution and reboot again.

With luck, this should sort your problems.

Skeletal

  SLAYER 12:33 03 Jan 07

other folk seem to be having problems with this game, when you have got your graphics card problem sorted,and Keef66's suggestion is a good one,I would take a look here.

click here

or here.

click here

  lothlann 13:12 03 Jan 07

O sorry my card is the 7600, i read the box wrong the first time, wasnt wearing my glasses :P

I will rty those things and report back later, thank you.

  lothlann 13:13 03 Jan 07

O and i just foudn out the random crashes arent just in Medieval so i think its the card and my hardware, not the game. I get the display issues in all games aswell.

  citadel 14:09 03 Jan 07

what about your psu system req 400w with a 12v rating of 22a is recommended. if your card is not getting a stable power supply it will cause shutdowns.

  Totally-braindead 14:21 03 Jan 07

The card could be faulty, as one of mine was when I upgrade a while back, or as citadel has pointed out it could be the power supply.

  lothlann 14:25 03 Jan 07

How can i check my power supply?

i had same issues after upgrade to 7600 it was indeed my 300 watt psu struggling, i would go for at least 500watt

i got this one click here

This thread is now locked and can not be replied to.

What is Amazon Go and will it come to the UK? The store without checkouts or queues

1995-2015: How technology has changed the world in 20 years

Why ecommerce hasn't taken off on social media

New MacBook Pro 2016 review | MacBook Pro with Touch Bar review: Apple's expensive and powerful…