Weird Floppy Drive Problem

  gardener 00:01 05 Oct 04
Locked

When I put a floppy disk into my A drive and view the files through Explorer I see the contents OK.However, if I replace the floppy disk with another, the contents of the previous floppy are showing.I've used different file viewers,checked the drive in Device Manager (it says it is working properly) and run various hardware diagnostics and everything indicates that it is functioning correctly.

I am baffled and annoyed especially as none of my rescue disks work,most worryingly my Partition Magic disks.

Can anyone suggest a reason for this bizarre behaviour please?My OS is XP Pro if that helps.

  pc moron 00:08 05 Oct 04

When you insert the second floppy disk and select View> Refresh- what happens?

  gardener 00:27 05 Oct 04

Good Morning.

It still shows the contents of the first disk.

  JonnyTub 00:31 05 Oct 04

try closing the window before you remove the floppy disk and opening a new one (by double clicking on a:) when you insert the new disk.

  gardener 00:42 05 Oct 04

Thanks for the tip but it will not work unfortunately.

The strange thing is that,even with the a second disk in the drive I can still open the contents of the first disk,up to a point.For example,the first disk contains a Zip file and a Read Me text file.I can read the text file and Winzip will attempt to open the Zip file but throws up an error message,obviously because another floppy drive is in the A drive.

Could it be a memory problem?

  gardener 00:51 05 Oct 04

Must shut myself down now.If anyone can suggest anything I'll check here later today.Thanks.

  pc moron 00:54 05 Oct 04

I don't know what to make of it.

If you can post more information, ie:

What you've tried, error messages etc, that will help us towards a solution.

  gardener 12:54 05 Oct 04

I've been reading my PC hardware reference book and I've found the answer to my problem!Apparently it is known as the 'phantom drive'problem.When you change a disk in the floppy drive a signal is sent via pin 34 of the ribbon cable telling the PC that another disk has been inserted.

I found that the ribbon cable connection to the motherboard had come loose so that pin 34 was not connecting properly.I reseated the connector and everything works.

Thanks to pc moron and JonnyTub for their suggestions.

  pc moron 13:22 05 Oct 04

Pleased it's sorted.

I was going to suggest reseating the cable after reading this click here

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

Best Christmas Agency Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…