WD My Book Elite - External Drive - 2TB - Urgent help required

  Angry Kid 21:40 PM 25 Mar 13
Locked

Evening,

I hope someone is able to help me.

I have two external hard drives and both are connected to my pc all of the time as one is accessible by my wife and the other for system back ups or saving additional information.

However, I have noticed that my main back up drive is no longer visible / accessible through WD Smart View and was previously protected by a password. The display on the front of the drive is no longer lit and I am just left with a white dot of a light on the front to signify that power is connected. I have check all power / usb leads and all work fine and the pc recognises the connection of the drive with a sound but still this drive remains invisible and not displayed even in my computer.

Therefore, I am in need of some help as trawling through various forums I have drawn a blank on where to go next.

Any help in trying to access my drive would be greatly appreciated.

Angry ;-))

  Fruit Bat /\0/\ 22:22 PM 25 Mar 13

If you cannot see it in Computer can you see it in Disk management?

  Angry Kid 22:30 PM 25 Mar 13

Evening Fruit Bat /\0/\,

I have just checked and cannot see my drive in here.

I am aware that my other WD My Book is active as I can hear it running but no sound coming from my problem drive.

Angry ;-)

  Fruit Bat /\0/\ 22:34 PM 25 Mar 13

Shut down and reboot see if the drive appears then.

If not then its looking like either

a bad connection to the drive in its caddy or the drive has failed.

  Angry Kid 22:37 PM 25 Mar 13

Fruit Bat /\0/\

I have rebooted on several occasions over the weekend when trying to investigate this problem but to no avail.

As I get a connection sound on connecting usb cable to my drive / Windows 8 pc I therefore presume my drive has failed.

Angry ;-)

  Fruit Bat /\0/\ 22:40 PM 25 Mar 13

connection sound usually means windows has detected the usb interface but worth looking in device manager a drives and usb to check no exclamation mark.

  Angry Kid 22:43 PM 25 Mar 13

Fruit Bat /\0/\

Checked in Device Manager and can only see the current external drive that is connected and not the problem drive.

No sign of any exclamation mark.

Angry ;-)

  Fruit Bat /\0/\ 23:03 PM 25 Mar 13

Next thing to do is

Remove power supply

Disconnect from PC

open up the drive and check connections

If they look OK the you could try connecting direct to a sata port on your mother board and using a power connection from your PSU.

or connect the dive into another caddy.

Advertisement

This thread is now locked and can not be replied to.

Should I upgrade to Windows 10? Windows 10 is now available, so do you have to upgrade? 8 reasons…

Why Vodafone’s frequency choice should interest you: The benefits of 800MHz

Digital visionaries discuss Designing the Future

How to run Windows 10 on Mac: How to run Windows 10 using Boot Camp or VirtualBox to install…