Want to back up but drives not showing.

  bumpkin 23 Dec 11
Locked
Answered

Hello I hope someone can help. Using XP Pro on a reasonably decent machine. Have three internal hard drives Seagate 500gb, Maxtor 320gb both SATA. Also a Seagate 160 ATA but this does not show nor can I access it even though it is connected properly. I would like to use this as a backup drive Acronis being the software. Also have 1T external HDD usb but that does not show either in my computer.

Ray

  northumbria61 23 Dec 11

Try going to Control Panel - Folder Options - View Tab - Hidden Files and Folders - make sure Hidden Files, Folders and Drives is selected - Apply - OK.

  bumpkin 24 Dec 11

Thanks but that was not the solution, I have removed the ATA drive as I am not sure it works too well so remove it from the equation. Which means why can I not see my external usb HDD so I can use it to back up with which was the only reason I bought it in first place.

  robin_x 24 Dec 11

Could be BIOS.

New CR2032 battery from the supermarket/computer shop tomorrow morning?

Could be lots of other stuff too.

I am sure your HDD will not fail in next few days.

Risk it and have a nice Christmas.

(make a Linux Live CD for relatives)

  lotvic 24 Dec 11

Have you tried the ext HDD in a different USB port?

  ICF 24 Dec 11

Are both the drive that don't show up new to your computer are have they never shown up?

  chub_tor 24 Dec 11

Does it show in Disk Management? Right Click My Computer, Click on Manage then scroll down and click on Disk Management. If no drive letter is assigned it won't show up so right click it and assign a drive letter.

  Jollyjohn 24 Dec 11

Is the external drive getting enough power? Does it have it's own power supply?

  bumpkin 24 Dec 11

Hi, and Merry Christmas to all. I have a spare BIOS battery so can try that. The drive used to show as I was using it as my back up until now. Has its own power supply and tried other USB ports to no avail. It does show in device manager but I cannot find how to assign a drive letter as suggested, right clicking on it does not provide that option unless it is me being thick. Thanks for your replies.

Ray

  bumpkin 24 Dec 11

Shows in device manager as Hitachi USB device. Not showing in Disk Management.

  robin_x 24 Dec 11

Try Partition Wizard

See if anything. (can also assign Drive Letters. Right clcick the partition)

No replies from me now, unless a few mins spare.

Advertisement

This thread is now locked and can not be replied to.

Should I upgrade to Windows 10? 8 reasons why you should upgrade to Windows 10... and 2 why you…

We are being sold the ability to spend money we don't have. And we love it

IKinema aims to banish droopy shoulders and wonky spines in animated CG characters

How to use Apple Music in the UK: Complete guide to Apple Music's features

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message